Project

Profile

Help

Task #4371

Document how to use the newly added recursive_conservative

Added by kersom over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
2.19.0
Groomed:
Yes
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Sprint 50
Quarter:

Description

Pulp 2.18.1 is introducing a new flag to `recursive_conservative`.

It is not clear in the documentation how this new flag should be used, and how to use this with already existent `recursive` flag.

I suggest this use case use to be added to the documentatio

dev_baseline_meeting.log (2.5 KB) dev_baseline_meeting.log Raw Meeting notes bherring, 02/19/2019 04:53 PM

Related issues

Related to RPM Support - Issue #4152: Regression Pulp 2.17.1: recursive copy of RPMs does not copy partially resolvable dependenciesCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to RPM Support - Issue #4375: Recursive copy doesn't solve rich dependencies correctlyCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Copied to RPM Support - Test #4543: Test newly described definitions of recursive and recursive_conservative flagsCLOSED - COMPLETE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 1f78c0fa View on GitHub
Added by bherring over 1 year ago

Updating MODULE_FIXTURES_ERRATA to account for --recursive copy

Updates to the definition of --recursive and --recursive_conservative are now defined in documentation with PR #1289 and Redmine Story

The amount of units copied on a --recursive eratta copy is now updated to reflect that change.

refs #4371

Revision 3ef23a3a View on GitHub
Added by ttereshc over 1 year ago

Add docs describing behavior of recursive flags

closes #4371 https://pulp.plan.io/issues/4371

History

#1 Updated by kersom over 1 year ago

  • Related to Issue #4152: Regression Pulp 2.17.1: recursive copy of RPMs does not copy partially resolvable dependencies added

#2 Updated by kersom over 1 year ago

  • Description updated (diff)

#3 Updated by kersom over 1 year ago

  • Related to Issue #4375: Recursive copy doesn't solve rich dependencies correctly added

#4 Updated by bherring over 1 year ago

  • Description updated (diff)

QE Notes

Specific to #4364 , I am not sure at this time what all the defined behaviors and full interesting permutations should be.

This is partly due to documentation of functionality with all available flags, previous modular content on a copied server.

Also, it is partly due to modularity is currently non-testable in 2.19master [0]. Therefore, I cannot tell you what Pulp 2.19 actually does, and if we are OK with that.

For simplicity of information discover-ability, here are my current questions.

If there is a development test fixture created, PLEASE link me to it so I do not have to recreate the wheel.

If anything is not clear, please reach me for questions.

Also, if there are `conical` answers generated, please put those in this RM ticket in the top!

Thanks!

#4364 Test Permutation Questions

Questions and Answers

recursive and recursive_conservative

  • The recursive/recursive_conservative flags should not affect how modular artifacts are copied, correct? All module + dependencies for all versions should be copied always, right?
    • not specifying 'recursive' should copy the module and all of it's artifacts
      [13:47:25] <dkliban>when --recursive is specified the module, it's artifacts, and it's modular dependencies their artifacts should be copied
it's possible for modular RPMs to have non-modular dependencies?
  • Yes (answered by Tanya)
Notes

Should Test Items, Basic:

  • With modular only for basic tests
  • With Mixed-repo for basic tests (same results as modular)
  • with recursive == False (only the module specified)
  • with recursive == True (module + modular deps)
  • With recursive_conservative == Either, should not change either above.
  • Same, but with Mixed-repo (unsure if the non-modular units would be copied as well -- think so)

Should Test Edge Cases:

  • Mixed-repo, NEVRA over-lap and copy content modules
    • Verify what and how many are copied
    • Believe the same as above, however initial setup has additional over-lapping NEVRA versions on A to copy to B

References

[0] - https://pulp.plan.io/issues/4364#note-3

#5 Updated by ttereshc over 1 year ago

  • Groomed changed from No to Yes
  • Sprint set to Sprint 49

#6 Updated by bherring over 1 year ago

Update

Had a meeting with Tanya, Kersom, Daniel, and Dennis about the above questions.

Attached a raw output of that meeting.

Will continue to process and evaluate how to use that information for modular depsolv testing in #4364

#7 Updated by ttereshc over 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#8 Updated by ttereshc over 1 year ago

  • Status changed from ASSIGNED to POST

#9 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 49 to Sprint 50

#10 Updated by ttereshc over 1 year ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by bherring over 1 year ago

  • Copied to Test #4543: Test newly described definitions of recursive and recursive_conservative flags added

#12 Updated by ttereshc over 1 year ago

  • Platform Release set to 2.19.0

#13 Updated by ttereshc over 1 year ago

  • Sprint/Milestone set to 2.19.0

#14 Updated by ttereshc over 1 year ago

  • Status changed from MODIFIED to 5

#15 Updated by ttereshc over 1 year ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#16 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF