Project

Profile

Help

Refactor #4291

Use DeclarativeVersion provided by pulpcore-plugin

Added by ttereshc almost 2 years ago. Updated 12 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Sprint:
Sprint 49
Quarter:

Description

To use all the features and changes introduced in the plugin API for a DeclarativeVersion, RPM plugin should subclass DeclarativeVersion and define its own pipeline_stages in a sync task.
E.g. currently different sync modes don't work for RPM plugin since it's enforced in DeclarativeVersion in the core.


Related issues

Is duplicate of RPM Support - Refactor #3945: Start using DeclarativeVersion againCLOSED - DUPLICATE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision a2b6813e View on GitHub
Added by ttereshc almost 2 years ago

Customize and use DeclarativeVersion provided by pulpcore-plugin

Also use package filename as a relative_path to avoid issues with different upstream directory structures. All packages are published at a root of a repo now.

closes #4291 https://pulp.plan.io/issues/4291

History

#1 Updated by bmbouter almost 2 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

This looks correct to me. Thanks ttereshc!

#2 Updated by bmbouter almost 2 years ago

  • Sprint set to Sprint 47

#3 Updated by rchan almost 2 years ago

  • Sprint changed from Sprint 47 to Sprint 48

#4 Updated by ttereshc almost 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#5 Updated by dalley almost 2 years ago

  • Is duplicate of Refactor #3945: Start using DeclarativeVersion again added

#6 Updated by dalley almost 2 years ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

#7 Updated by ttereshc almost 2 years ago

  • Status changed from CLOSED - DUPLICATE to ASSIGNED

#8 Updated by ttereshc almost 2 years ago

  • Status changed from ASSIGNED to POST
  • Sprint changed from Sprint 48 to Sprint 49

#9 Updated by ttereshc almost 2 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#10 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

#11 Updated by ttereshc 12 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF