Project

Profile

Help

Task #3642

Story #3637: As a user, I can run pulp in a FIPS-enabled environment

Get Pulp 2 working with mongodb in a FIPS-enabled environment

Added by daviddavis over 3 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
2.16.2
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 38
Quarter:

Description

Pymongo will probably require a patch: https://bugzilla.redhat.com/show_bug.cgi?id=1064849

History

#2 Updated by daviddavis over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to daviddavis

#3 Updated by daviddavis over 3 years ago

#4 Updated by daviddavis over 3 years ago

  • Sprint set to Sprint 37

#5 Updated by daviddavis over 3 years ago

So apparently after doing some research, we've discovered that the pypi bson package is not what pymongo is using:

Do not install the “bson” package from pypi. PyMongo comes with its own bson package; doing “easy_install bson” installs a third-party package that is incompatible with PyMongo.

#7 Updated by daviddavis over 3 years ago

My PR got closed out. Seems like they are working on it for the next release of pymongo (3.7 maybe). Here's the ticket:

https://jira.mongodb.org/browse/PYTHON-1521

#8 Updated by daviddavis over 3 years ago

Going to wait another week on the above bug to see if they open a patch. Otherwise, I'll proceed with patching bson ourselves.

#9 Updated by rchan over 3 years ago

  • Sprint changed from Sprint 37 to Sprint 38

#10 Updated by daviddavis over 3 years ago

Looks like the pymongo folks have a patch which should work in FIPS:

https://github.com/mongodb/mongo-python-driver/commit/61850357a0e0eeec1a30e1adc0bbf7ebee807358

#11 Updated by daviddavis over 3 years ago

  • Status changed from ASSIGNED to POST

#12 Updated by daviddavis over 3 years ago

  • Status changed from POST to MODIFIED

Confirmed that patch for bson is in the nightly build of Pulp.

#13 Updated by dkliban@redhat.com over 3 years ago

  • Platform Release set to 2.16.2

#14 Updated by ipanova@redhat.com over 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#15 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF