Project

Profile

Help

Issue #3468

closed

Vagrant up broken for 3.0-dev branch

Added by CodeHeeler over 4 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

When I try to vagrant up qpid dependencies fail to install due to lack of gcc.

Changing the playbook to install rabbitmq fixed the problem.

Actions #1

Updated by CodeHeeler over 4 years ago

TASK [kombu_fixup : Install python-qpid-proton from PyPI] **********************
fatal: [pulp3_dev]: FAILED! => {"changed": false, "cmd": "/home/vagrant/.virtualenvs/pulp/bin/pip3 install python-qpid-proton", "msg": "stdout: Collecting python-qpid-proton\n  Downloading python-qpid-proton-0.21.0.tar.gz (399kB)\nInstalling collected packages: python-qpid-proton\n  Running setup.py install for python-qpid-proton: started\n    Running setup.py install for python-qpid-proton: finished with status 'error'\n    Complete output from command /home/vagrant/.virtualenvs/pulp/bin/python3 -u -c \"import setuptools, tokenize;__file__='/tmp/pip-build-aq3330ye/python-qpid-proton/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))\" install --record /tmp/pip-ysswgvfg-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/vagrant/.virtualenvs/pulp/include/site/python3.6/python-qpid-proton:\n    running install\n    running build\n    running build_ext\n    running configure\n    Did not find libqpid-proton via pkg-config:\n    Building the bundled proton-c sources into the extension\n    Did not find openssl via pkg-config:\n    Warning: OpenSSL not installed - disabling SSL support!\n    creating build\n    creating build/temp.linux-x86_64-3.6\n    creating build/temp.linux-x86_64-3.6/tmp\n    cc -c /tmp/clock_gettimelzrn2rfr.c -o build/temp.linux-x86_64-3.6/tmp/clock_gettimelzrn2rfr.o\n    /tmp/clock_gettimelzrn2rfr.c:1:1: warning: return type defaults to ‘int’ [-Wimplicit-int]\n     main (int argc, char **argv) {\n     ^~~~\n    /tmp/clock_gettimelzrn2rfr.c: In function ‘main’:\n    /tmp/clock_gettimelzrn2rfr.c:2:5: warning: implicit declaration of function ‘clock_gettime’ [-Wimplicit-function-declaration]\n         clock_gettime();\n         ^~~~~~~~~~~~~\n    cc build/temp.linux-x86_64-3.6/tmp/clock_gettimelzrn2rfr.o -o build/temp.linux-x86_64-3.6/a.out\n    cc -c /tmp/sasl_client_donebpcdpod7.c -o build/temp.linux-x86_64-3.6/tmp/sasl_client_donebpcdpod7.o\n    /tmp/sasl_client_donebpcdpod7.c:1:10: fatal error: sasl/sasl.h: No such file or directory\n     #include \"sasl/sasl.h\"\n              ^~~~~~~~~~~~~\n    compilation terminated.\n    Warning: Cyrus SASL not installed - only the ANONYMOUS and PLAIN mechanisms will be supported!\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/extra\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/handlers\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/messenger\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/sasl\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/platform\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor/io\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor/io/posix\n    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/ssl\n    gcc -pthread -Wno-unused-result -Wsign-compare -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Dqpid_proton_EXPORTS -DUSE_ATOLL -DUSE_STRERROR_R -DUSE_CLOCK_GETTIME -Ibuild/include -I/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/include -I/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src -c /tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object/object.c -o build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object/object.o -std=gnu99\n    gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory\n    error: command 'gcc' failed with exit status 1\n    \n    ----------------------------------------\n\n:stderr: Command \"/home/vagrant/.virtualenvs/pulp/bin/python3 -u -c \"import setuptools, tokenize;__file__='/tmp/pip-build-aq3330ye/python-qpid-proton/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))\" install --record /tmp/pip-ysswgvfg-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/vagrant/.virtualenvs/pulp/include/site/python3.6/python-qpid-proton\" failed with error code 1 in /tmp/pip-build-aq3330ye/python-qpid-proton/\n"}
Actions #2

Updated by Ichimonji10 over 4 years ago

Here's a formatted version of the message. Note that gcc is installed. The issue is:

    gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory

Full message:

>>> print(d['changed'])
False
>>> print(d['cmd'])
/home/vagrant/.virtualenvs/pulp/bin/pip3 install python-qpid-proton
>>> print(d['msg'])
stdout: Collecting python-qpid-proton
  Downloading python-qpid-proton-0.21.0.tar.gz (399kB)
Installing collected packages: python-qpid-proton
  Running setup.py install for python-qpid-proton: started
    Running setup.py install for python-qpid-proton: finished with status 'error'
    Complete output from command /home/vagrant/.virtualenvs/pulp/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-aq3330ye/python-qpid-proton/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ysswgvfg-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/vagrant/.virtualenvs/pulp/include/site/python3.6/python-qpid-proton:
    running install
    running build
    running build_ext
    running configure
    Did not find libqpid-proton via pkg-config:
    Building the bundled proton-c sources into the extension
    Did not find openssl via pkg-config:
    Warning: OpenSSL not installed - disabling SSL support!
    creating build
    creating build/temp.linux-x86_64-3.6
    creating build/temp.linux-x86_64-3.6/tmp
    cc -c /tmp/clock_gettimelzrn2rfr.c -o build/temp.linux-x86_64-3.6/tmp/clock_gettimelzrn2rfr.o
    /tmp/clock_gettimelzrn2rfr.c:1:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
     main (int argc, char **argv) {
     ^~~~
    /tmp/clock_gettimelzrn2rfr.c: In function ‘main’:
    /tmp/clock_gettimelzrn2rfr.c:2:5: warning: implicit declaration of function ‘clock_gettime’ [-Wimplicit-function-declaration]
         clock_gettime();
         ^~~~~~~~~~~~~
    cc build/temp.linux-x86_64-3.6/tmp/clock_gettimelzrn2rfr.o -o build/temp.linux-x86_64-3.6/a.out
    cc -c /tmp/sasl_client_donebpcdpod7.c -o build/temp.linux-x86_64-3.6/tmp/sasl_client_donebpcdpod7.o
    /tmp/sasl_client_donebpcdpod7.c:1:10: fatal error: sasl/sasl.h: No such file or directory
     #include "sasl/sasl.h"
              ^~~~~~~~~~~~~
    compilation terminated.
    Warning: Cyrus SASL not installed - only the ANONYMOUS and PLAIN mechanisms will be supported!
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/extra
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/handlers
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/messenger
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/sasl
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/platform
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor/io
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/reactor/io/posix
    creating build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/ssl
    gcc -pthread -Wno-unused-result -Wsign-compare -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Dqpid_proton_EXPORTS -DUSE_ATOLL -DUSE_STRERROR_R -DUSE_CLOCK_GETTIME -Ibuild/include -I/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/include -I/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src -c /tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object/object.c -o build/temp.linux-x86_64-3.6/tmp/pip-build-aq3330ye/python-qpid-proton/proton-c/src/core/object/object.o -std=gnu99
    gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory
    error: command 'gcc' failed with exit status 1

    ----------------------------------------

:stderr: Command "/home/vagrant/.virtualenvs/pulp/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-aq3330ye/python-qpid-proton/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-ysswgvfg-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/vagrant/.virtualenvs/pulp/include/site/python3.6/python-qpid-proton" failed with error code 1 in /tmp/pip-build-aq3330ye/python-qpid-proton/

Added by Jeremy Audet over 4 years ago

Revision 124ac097

Install dep for python-qpid-proton on Fedora cloud

python-qpid-proton depends on redhat-rpm-config on Fedora cloud images.

closes #3468 https://pulp.plan.io/issues/3468

Actions #3

Updated by Anonymous over 4 years ago

  • Status changed from NEW to MODIFIED
Actions #4

Updated by dkliban@redhat.com over 4 years ago

  • Sprint/Milestone set to 3.0.0
Actions #5

Updated by bmbouter over 3 years ago

  • Tags deleted (Pulp 3, Pulp 3 MVP)
Actions #6

Updated by bmbouter almost 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF