Project

Profile

Help

Story #3359

closed

Anyone should have the option to install Pulp with SQLite3 as the default DB

Added by milan over 6 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
3.0.0
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Sprint:
Sprint 33
Quarter:

Description

Based on the Plugin Writer's Coding Workshop Feedback, users requested SQLite3 be the default database type.

  • folks might feel strong about what additional services have to run on their (personal) systems
  • smaller production deployments out there might be OK with SQLite
  • plug-in writers don't necessarily have to run their code against Postgresql (right away)
  • to have the flexibility in choosing a DB during installation, based on target deployment environment

The deliverables are outlined in checklist items.

Also available in: Atom PDF