Project

Profile

Help

Issue #301

Http Event Listener: repo.sync.finish: task error not reported

Added by mkovacik@redhat.com almost 7 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Http Event Listener for the repo.sync.finish type fails to propagate related task error

How reproducible:
Always, automated

Steps to reproduce:
- create an rpm repo with a deliberately wrong feed url
- create a bin in http://requestb.in
- create an http event listener reporting to the bin.url
- update the event listener to type: ['repo.sync.finish']
- run repo sync
- wait till the repo sync tasks finishes
- assert the task finished with an error state
- check the bin.requests

Actual results
- bin.requests[0].body contains a running task call_report data

Expected results
- bin.requests[0].body contains a failed-task call_report data

Additional information
- feels like a duplicate of Issue #297
- pulp-automation test case: test_23_event_listener:EventListenerErrorTest.test_01_repo_sync_finish
- https://github.com/RedHatQE/pulp-automation/blob/master/tests/general_tests/test_23_event_listener.py

screen.log (24.6 KB) screen.log Test case screen log mkovacik@redhat.com, 02/25/2015 04:18 PM

Related issues

Related to Pulp - Issue #297: Http Event Listener: repo.sync.finish fires with task in running stateCLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mkovacik@redhat.com almost 7 years ago

  • Category set to 14
  • Version set to 2.6 Beta

Version:
pulp-server-2.6.0-0.7.beta.fc21.noarch

#2 Updated by ipanova@redhat.com over 6 years ago

  • Status changed from NEW to 7

#3 Updated by dkliban@redhat.com over 6 years ago

  • Triaged changed from No to Yes

#4 Updated by bmbouter over 6 years ago

  • Status changed from 7 to CLOSED - WONTFIX

#5 Updated by bmbouter over 2 years ago

  • Severity set to 2. Medium

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#7 Updated by bmbouter over 1 year ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF