Project

Profile

Help

Issue #2738

Errata package list exceed mongod 16MB document size limit.

Added by jortel@redhat.com over 4 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.7
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

During a sync, the errata package list exceeds the mongod 16MB document size limit.

Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528) Could not save document (BSONObj size: 16797620 (0x1004FB4) is invalid. Size must be between 0 and 16793600(16MB) First element: _id: "58ba0673-85d8-4c5d-a327-6b1b85797b55")
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528) Traceback (most recent call last):
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 275, in run
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     self.get_errata(metadata_files)
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 794, in get_errata
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     updateinfo.process_package_element, additive_type=True)
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 887, in save_fileless_units
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     model = self._concatenate_units(existing_unit, model)
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 932, in _concatenate_units
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     existing_unit.merge_errata(new_unit)
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/db/models.py", line 705, in merge_errata
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     self.merge_pkglists_and_save(other)
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/db/models.py", line 802, in merge_pkglists_and_save
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)     self.save()
Apr 26 17:26:30 ps2ar022911 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (32160-98528)   File "/usr/lib/python2.7/site-packages/mongoengine/document.py", line 398, in save

Related issues

Is duplicate of RPM Support - Issue #2568: DocumentTooLarge error during merge of errata pkglistsCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jortel@redhat.com over 4 years ago

  • Description updated (diff)

#2 Updated by jortel@redhat.com over 4 years ago

  • Version set to 2.8.7

#3 Updated by ttereshc over 4 years ago

  • Is duplicate of Issue #2568: DocumentTooLarge error during merge of errata pkglists added

#4 Updated by ttereshc over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF