Project

Profile

Help

Issue #2639

Upgrade fails on Fedora

Added by semyers 9 months ago. Updated 6 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
Severity:
3. High
Version:
Platform Release:
2.13.2
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No

Description

https://paste.fedoraproject.org/paste/TxxGKBXa7zegjwSMpu-YNl5M1UNdIGYhyRLivL9gydE=

I think it's weird that this only affects the -common package, and not the others. I suspect it might have to do with this line in the spec:

https://github.com/pulp/pulp_ostree/blob/master/pulp-ostree.spec#L78

None of the other subpackages explicitly set '-n' to the package name in the package sections like -common does, so this stands out as a possible difference that makes the -common packages fail this way. I'm guessing rpm macro changes in f24 may have caused this to occur, and as far as I know this problem doesn't occur in f25, so an easy workaround is "upgrade to fedora 25".

Associated revisions

Revision 68d5eaac View on GitHub
Added by pcreech 9 months ago

Add provides for python2-* packages

Add provides for python2-* packages. Fedora downstream packages are
named python2-* and provide python-*. Upstream needs to mirror this for
dependency resolution to work properly

re #2687

Revision 74644572 View on GitHub
Added by pcreech 9 months ago

Add provides for python2-* packages

Add provides for python2-* packages. Fedora downstream packages are
named python2-* and provide python-*. Upstream needs to mirror this for
dependency resolution to work properly

re #2687

Revision 244ca219 View on GitHub
Added by pcreech 9 months ago

Add provides for python2-* packages

Add provides for python2-* packages. Fedora downstream packages are
named python2-* and provide python-*. Upstream needs to mirror this for
dependency resolution to work properly

re #2687

Revision 9c7f7e46 View on GitHub
Added by pcreech 9 months ago

Add provides for python2-* packages

Add provides for python2-* packages. Fedora downstream packages are
named python2-* and provide python-*. Upstream needs to mirror this for
dependency resolution to work properly

re #2687

Revision 834e7cf6 View on GitHub
Added by pcreech 9 months ago

Add provides for python2-* packages

Add provides for python2-* packages. Fedora downstream packages are
named python2-* and provide python-*. Upstream needs to mirror this for
dependency resolution to work properly

re #2687

History

#1 Updated by semyers 9 months ago

Something else that's odd is that, to the best of my knowledge, we didn't see then when upgrading from 1.1.z to 1.2.z in 2.12.0 or 2.12.1. Because of this, and the fact that it appears to be fixed again in Fedora 25, leads me to thinking that this is a maybe a dnf bug that got fixed, but for whatever reason isn't fixed in Fedora 24. There might be things we can do to fix it, but it also might just fix itself.

#2 Updated by semyers 9 months ago

I was wrong, we don't yet know if fedora 25 is affected or not. If this is affecting fedora 25 as well as fedora 24, I think that would have a significant impact on the severity of this. Some more investigation is needed.

#3 Updated by bizhang 9 months ago

  • Sprint/Milestone set to Sprint 17

#4 Updated by bizhang 9 months ago

  • Triaged changed from No to Yes

#5 Updated by pthomas@redhat.com 9 months ago

Looking in Jenkins for upgrade jobs 2.10 -> 2.12.2 beta and 2.11 ->2.12.2 beta

2.10 -> 2.12.2 beta failed on F24

fatal: [localhost]: FAILED! => {"changed": true, "cmd": "dnf -y update", "delta": "0:00:30.450133", "end": "2017-03-16 23:42:58.461305", "failed": true, "rc": 1, "start": "2017-03-16 23:42:28.011172", "stderr": "Error: Transaction check error:\n  file /usr/lib/python2.7/site-packages/pulp_ostree/__init__.pyc from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/__init__.pyc from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/extensions/__init__.pyc from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/__init__.pyo from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/__init__.pyo from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/extensions/__init__.pyo from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/constants.py from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/constants.pyc from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/constants.pyo from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/errors.py from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/errors.pyc from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n  file /usr/lib/python2.7/site-packages/pulp_ostree/common/errors.pyo from install of python-pulp-ostree-common-1.2.1-0.1.beta.fc24.noarch conflicts with file from package python2-pulp-ostree-common-1.1.2-1.fc24.noarch\n\nError Summary\n-------------", "stdout": "Last metadata expiration check: 0:00:06 ago on Thu Mar 16 23:42:47 2017.\nDependencies 

2.11 -> 2.12.2 beta on F25


TASK [pulp-upgrade : Update packages] ******************************************
fatal: [localhost]: FAILED! => {"changed": true, "cmd": "dnf -y update", "delta": "0:00:30.402367", "end": "2017-03-20 08:35:51.346206", "failed": true, "rc": 1, "start": "2017-03-20 08:35:20.943839", "stderr": "/usr/share/locale/de/LC_MESSAGES/cryptsetup.mo: No such file or directory\ncannot reconstruct rpm from disk files\nError: Transaction check error:\n  file /usr/lib/python2.7/site-packages/pulp_docker/__init__.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/__init__.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/extensions/__init__.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/__init__.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/__init__.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/extensions/__init__.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/constants.py from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/constants.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/constants.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/error_codes.py from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/error_codes.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/error_codes.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/tags.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/tags.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/tarutils.pyc from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n  file /usr/lib/python2.7/site-packages/pulp_docker/common/tarutils.pyo from install of python-pulp-docker-common-2.3.0-1.fc25.noarch conflicts with file from package python2-pulp-docker-common-2.1.0-2.fc25.noarch\n\nError Summary\n-------------", "stdout": "Last metadata expiration check: 0:00:17 ago on Mon Mar 20 08:35:29 2017.\nDependencies 

#6 Updated by semyers 9 months ago

And those upgrades are not from the versions available in fedora, correct?

#7 Updated by semyers 9 months ago

  • OS deleted (Fedora 24)
  • Blocks Release 2.12.z, 2.13.z added

We decided this that this does block 2.12.2's release; updating accordingly.

#9 Updated by semyers 9 months ago

Talking with elyezer, we might also be seeing these failures with the python plugin. I suspect that at least python, ostree, and docker are affected, but dnf is maybe giving up after the first package is found with apparently broken dependencies, so we don't see all affected packages. This is my guess at why we aren't seeing the same failure on different platforms: for whatever reason dnf processes different packages first on different platforms when going through the upgrade transaction.

#10 Updated by semyers 9 months ago

  • Blocks Release deleted (2.12.z, 2.13.z)

This has been found to have been affecting our fedora releases published at repos.fedorapeople.org since at least Pulp 2.10, indicating that it is not a regression, and does not constitute a release blocker.

#11 Updated by pcreech 9 months ago

This issue seems similar to one we had on pulp platform that was resolved (for platform) in 2.10. The fix at the time was to have upstream 'provide' python2-* packages in the spec file.

https://github.com/pulp/pulp/pull/2791

This should be evaluated to see if doing this across the board for all plugins will resolve these issues.

#12 Updated by pcreech 9 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to pcreech

#14 Updated by pcreech 9 months ago

  • Status changed from ASSIGNED to POST

#15 Updated by mhrivnak 8 months ago

  • Sprint/Milestone changed from Sprint 17 to Sprint 18

#16 Updated by pcreech 8 months ago

  • Status changed from POST to MODIFIED

#17 Updated by pcreech 8 months ago

  • Platform Release set to 2.13.0
  • Target Release - OSTree set to 1.2.1

#18 Updated by pcreech 8 months ago

  • Status changed from MODIFIED to ON_QA

#19 Updated by pthomas@redhat.com 8 months ago

  • Project changed from OSTree Support to Pulp
  • Subject changed from Upgrade to 1.2.1 beta fails on fedora 24 to Upgrade fails on Fedora
  • Status changed from ON_QA to ASSIGNED
  • Triaged changed from Yes to No

#20 Updated by pcreech 8 months ago

  • Platform Release deleted (2.13.0)

#21 Updated by ttereshc 8 months ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#22 Updated by jortel@redhat.com 8 months ago

  • Sprint/Milestone changed from Sprint 18 to Sprint 19

#23 Updated by mhrivnak 7 months ago

  • Sprint/Milestone changed from Sprint 19 to Sprint 20

#25 Updated by pcreech 7 months ago

  • Status changed from POST to MODIFIED

#26 Updated by pcreech 6 months ago

  • Platform Release set to 2.13.2

#27 Updated by pcreech 6 months ago

  • Status changed from MODIFIED to ON_QA

#28 Updated by pcreech 6 months ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF