Project

Profile

Help

Issue #2605

Ovirt, Openstack | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml

Added by pulp-issues@lagis.at almost 5 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.12.0
Platform Release:
2.13.1
OS:
RHEL 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 19
Quarter:

Description

Hello,

when I try to sync those Repos. I get the error:
Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml

However I can use those Repos with yum directly, without a problem.

Repos:

ovirt367_64
http://resources.ovirt.org/pub/ovirt-3.6/rpm/el7/
ovirt407_64
http://mirror.centos.org/centos/7/virt/x86_64/ovirt-4.0/
ovirt417_64
http://resources.ovirt.org/pub/ovirt-4.1/rpm/el7/

openstack-liberty7_64
http://mirror.centos.org/centos/7/cloud/x86_64/openstack-liberty/
openstack-newton7_64
http://mirror.centos.org/centos/7/cloud/x86_64/openstack-newton/

The Problem started at 2017-01-30 with the ovirt repos. My other 37 Repos Sync without a Problem.

Is there anything else I can do to resolve this Problem?


Related issues

Has duplicate Pulp - Issue #2695: Malformed repository errorCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 4bc26153 View on GitHub
Added by fdobrovo almost 5 years ago

Ignore duplicate packages in metadata

We can now sync from repository which have the same package more than once enlisted in the metadata.

closes #2605 https://pulp.plan.io/issues/2605

Revision f9833be9 View on GitHub
Added by fdobrovo over 4 years ago

Ignore duplicate packages in metadata

We can now sync from repository which have the same package more than once enlisted in the metadata.

closes #2605 https://pulp.plan.io/issues/2605

History

#1 Updated by ttereshc almost 5 years ago

I reproduced it with provided repo:

ovirt367_64
http://resources.ovirt.org/pub/ovirt-3.6/rpm/el7/

The issue seems to be in a way we count packages in metadata files.
gdbm handle gives wrong number of units (in comparison to simple grep through the metadata files or counter in the loop):
https://github.com/pulp/pulp_rpm/blob/2.12-release/plugins/pulp_rpm/plugins/importers/yum/repomd/metadata.py#L321

It would be good to figure out why before switching to just plain counter in the loop, because this issue happens only to a limited number of repositories, maybe there is some data specific problem.

#2 Updated by bizhang almost 5 years ago

  • Sprint/Milestone set to 33
  • Triaged changed from No to Yes

#3 Updated by fdobrovo almost 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to fdobrovo

#4 Updated by mhrivnak almost 5 years ago

  • Sprint/Milestone changed from 33 to 34

#6 Updated by fdobrovo almost 5 years ago

  • Status changed from ASSIGNED to POST

#7 Updated by mhrivnak almost 5 years ago

  • Sprint/Milestone changed from 34 to 36

#8 Updated by ttereshc almost 5 years ago

  • Has duplicate Issue #2695: Malformed repository error added

#9 Updated by mhrivnak almost 5 years ago

  • Sprint/Milestone changed from 36 to 37

#10 Updated by jortel@redhat.com over 4 years ago

  • Sprint/Milestone changed from 37 to 38

#11 Updated by fdobrovo over 4 years ago

  • Status changed from POST to MODIFIED

#12 Updated by bizhang over 4 years ago

  • Project changed from Pulp to RPM Support

#13 Updated by fdobrovo over 4 years ago

#14 Updated by bizhang over 4 years ago

  • Platform Release set to 2.13.1

#15 Updated by bizhang over 4 years ago

  • Status changed from MODIFIED to 5

#16 Updated by bmbouter over 4 years ago

User tested by the community. Thanks Simon! https://www.redhat.com/archives/pulp-list/2017-May/msg00020.html

#17 Updated by bizhang over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#18 Updated by bmbouter almost 4 years ago

  • Sprint set to Sprint 19

#19 Updated by bmbouter almost 4 years ago

  • Sprint/Milestone deleted (38)

#20 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF