Project

Profile

Help

Issue #2485

Add documentation about the need of restart pulp_streamer when upgrading to Pulp 2.11 from old versions

Added by elyezer over 3 years ago. Updated 2 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.11.0
Platform Release:
2.11.0
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:

Description

The documentation should state the need of stopping pulp_streamer before upgrading and starting it after the upgrade when upgrading from older versions.

If that is not done, then Pulp will raise errors like the following which was raised on a RHEL7 system where Pulp was upgraded from 2.10 to 2.11 RC2:

[-] 127.0.0.1 - - [13/Dec/2016:13:32:52 +0000] "GET /var/lib/pulp/content/units/rpm/69/1a5163e40406d94c52213ff3cb5b015028d06569c1dd1bf05a41aefe2659b3/giraffe-0.67-2.noarch.rpm HTTP/1.1" 500 - "-" "python-requests/2.6.0 CPython/2.7.5 Linux/3.10.0-514.el7.x86_64"
Download of /var/lib/pulp/content/units/rpm/69/1a5163e40406d94c52213ff3cb5b015028d06569c1dd1bf05a41aefe2659b3/giraffe-0.67-2.noarch.rpm failed: Internal Server Error.
An unexpected error occurred while handling the request.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/streamer/server.py", line 187, in _handle_get
    self._download(catalog_entry, request, responder)
  File "/usr/lib/python2.7/site-packages/pulp/streamer/server.py", line 216, in _download
    catalog_entry.importer_id)
  File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 475, in get_importer_by_id
    try:
  File "/usr/lib/python2.7/site-packages/mongoengine/queryset/base.py", line 238, in get
    result = queryset.next()
  File "/usr/lib/python2.7/site-packages/mongoengine/queryset/base.py", line 1411, in next
    _auto_dereference=self._auto_dereference, only_fields=self.only_fields)
  File "/usr/lib/python2.7/site-packages/mongoengine/base/document.py", line 730, in _from_son
    obj = cls(__auto_convert=False, _created=created, __only_fields=only_fields, **data)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/model/__init__.py", line 55, in __init__
    super(AutoRetryDocument, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/mongoengine/base/document.py", line 80, in __init__
    raise FieldDoesNotExist(msg)
FieldDoesNotExist: The field 'last_updated' does not exist on the document 'Importer'
Dec 13 08:32:52 pulp-server.example.com pulp_streamer[13363]: [-] 127.0.0.1 - - [13/Dec/2016:13:32:52 +0000] "GET /var/lib/pulp/content/units/rpm/c1/c792701121eeb0dc728fa7cb93389a2185048fe406c0ce101f3e4d742148a0/crow-0.8-1.noarch.rpm HTTP/1.1" 500 - "-" "python-requests/2.6.0 CPython/2.7.5 Linux/3.10.0-514.el7.x86_64"
Download of /var/lib/pulp/content/units/rpm/c1/c792701121eeb0dc728fa7cb93389a2185048fe406c0ce101f3e4d742148a0/crow-0.8-1.noarch.rpm failed: Internal Server Error.

The pulp_streamer can be done after the upgrade if that is missed during upgrade time. That can also be stated in the documentation.

Associated revisions

Revision 55e2dc1d View on GitHub
Added by bmbouter over 3 years ago

Adds upgrade notes to 2.11

The upgrade notes added also include stopping and starting pulp_streamer.

This commit is based off of the 'pulp-2.11.0-0.5.rc'. This allows us to merge it into the 2.11 GA release at build time, and also merge it into 2.11-dev and forward using our normal PR process.

https://pulp.plan.io/issues/2485 closes #2485

Revision 55e2dc1d View on GitHub
Added by bmbouter over 3 years ago

Adds upgrade notes to 2.11

The upgrade notes added also include stopping and starting pulp_streamer.

This commit is based off of the 'pulp-2.11.0-0.5.rc'. This allows us to merge it into the 2.11 GA release at build time, and also merge it into 2.11-dev and forward using our normal PR process.

https://pulp.plan.io/issues/2485 closes #2485

History

#1 Updated by pthomas@redhat.com over 3 years ago

I have reproduced the same in EL6 as well

[root@mgmt13 ~]# pulp-admin repo download --repo-id rhel6
+----------------------------------------------------------------------+
                     Downloading Repository [rhel6]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Download Repository Content
[                                                  ] 0%
17 of 3865 items
... failed

Task Succeeded

Dec 13 08:46:01 mgmt13 pulp: celery.worker.strategy:INFO: Received task: pulp.server.controllers.repository.download_repo[67606e67-443e-4906-8cc2-398da210f4c3]
Dec 13 08:46:55 mgmt13 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): mgmt13.rhq.lab.eng.bos.redhat.com
Dec 13 08:46:55 mgmt13 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (2): mgmt13.rhq.lab.eng.bos.redhat.com
Dec 13 08:46:55 mgmt13 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (3): mgmt13.rhq.lab.eng.bos.redhat.com
Dec 13 08:46:55 mgmt13 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (4): mgmt13.rhq.lab.eng.bos.redhat.com
Dec 13 08:46:55 mgmt13 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (5): mgmt13.rhq.lab.eng.bos.redhat.com
Dec 13 08:46:55 mgmt13 rsyslogd-2177: imuxsock lost 6180 messages from pid 26159 due to rate-limiting
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432) An unexpected error occurred while handling the request.
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432) Traceback (most recent call last):
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 187, in _handle_get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     self._download(catalog_entry, request, responder)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 216, in _download
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     catalog_entry.importer_id)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 475, in get_importer_by_id
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     try:
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 238, in get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     result = queryset.next()
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 1411, in next
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     _auto_dereference=self._auto_dereference, only_fields=self.only_fields)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 730, in _from_son
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     obj = cls(__auto_convert=False, _created=created, __only_fields=only_fields, **data)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 55, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     super(AutoRetryDocument, self).__init__(*args, **kwargs)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 80, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432)     raise FieldDoesNotExist(msg)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-06432) FieldDoesNotExist: The field 'last_updated' does not exist on the document 'Importer'
Dec 13 08:46:55 mgmt13 pulp_streamer: [-] 127.0.0.1 - - [13/Dec/2016:13:46:54 +0000] "GET /var/lib/pulp/content/units/distribution/2f/d28bba0a3491db2f87801af971d4110acade9351bfde01e18400d0d295c658/HighAvailability/repodata/repomd.xml HTTP/1.1" 500 - "-" "python-requests/2.6.0 CPython/2.6.6 Linux/2.6.32-642.el6.x86_64"
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336) An unexpected error occurred while handling the request.
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336) Traceback (most recent call last):
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 187, in _handle_get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     self._download(catalog_entry, request, responder)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 216, in _download
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     catalog_entry.importer_id)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 475, in get_importer_by_id
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     try:
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 238, in get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     result = queryset.next()
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 1411, in next
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     _auto_dereference=self._auto_dereference, only_fields=self.only_fields)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 730, in _from_son
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     obj = cls(__auto_convert=False, _created=created, __only_fields=only_fields, **data)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 55, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     super(AutoRetryDocument, self).__init__(*args, **kwargs)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 80, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336)     raise FieldDoesNotExist(msg)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-54336) FieldDoesNotExist: The field 'last_updated' does not exist on the document 'Importer'
Dec 13 08:46:55 mgmt13 pulp_streamer: [-] 127.0.0.1 - - [13/Dec/2016:13:46:54 +0000] "GET /var/lib/pulp/content/units/distribution/2f/d28bba0a3491db2f87801af971d4110acade9351bfde01e18400d0d295c658/ResilientStorage/repodata/repomd.xml HTTP/1.1" 500 - "-" "python-requests/2.6.0 CPython/2.6.6 Linux/2.6.32-642.el6.x86_64"
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288) An unexpected error occurred while handling the request.
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288) Traceback (most recent call last):
Dec 13 08:46:55 mgmt13 pulp: pulp.server.controllers.repository:INFO: Download of /var/lib/pulp/content/units/distribution/2f/d28bba0a3491db2f87801af971d4110acade9351bfde01e18400d0d295c658/Server/repodata/repomd.xml failed: Internal Server Error.
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 187, in _handle_get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     self._download(catalog_entry, request, responder)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/pulp/streamer/server.py", line 216, in _download
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     catalog_entry.importer_id)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 475, in get_importer_by_id
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     try:
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 238, in get
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     result = queryset.next()
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/mongoengine/queryset/base.py", line 1411, in next
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     _auto_dereference=self._auto_dereference, only_fields=self.only_fields)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 730, in _from_son
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     obj = cls(__auto_convert=False, _created=created, __only_fields=only_fields, **data)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 55, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     super(AutoRetryDocument, self).__init__(*args, **kwargs)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)   File "/usr/lib/python2.6/site-packages/mongoengine/base/document.py", line 80, in __init__
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288)     raise FieldDoesNotExist(msg)
Dec 13 08:46:55 mgmt13 pulp_streamer: pulp.streamer.server:ERROR: (26159-96288) FieldDoesNotExist: The field 'last_updated' does not exist on the document 'Importer'

#2 Updated by dkliban@redhat.com over 3 years ago

Please provide exact steps to reproduce the problem. Thanks!

#3 Updated by mhrivnak over 3 years ago

Is this new in 2.11? or also present in 2.10?

#4 Updated by pthomas@redhat.com over 3 years ago

Steps to reproduce

1. Create a repo with on-demand download policy
2. Sync the repo 
3. Run repo download

<pre>
[root@mgmt13 ~]# pulp-admin rpm repo create --repo-id zoo --feed https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm/ --download-policy on_demand
Successfully created repository [zoo]

[root@mgmt13 ~]#
[root@mgmt13 ~]#

[root@mgmt13 ~]# pulp-admin rpm repo sync run --repo-id zoo
+----------------------------------------------------------------------+
                     Synchronizing Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       32/32 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Cleaning duplicate packages...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
32 of 32 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
4 of 4 items
... completed

Publishing Comps file
[==================================================] 100%
4 of 4 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Generating HTML files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

[root@mgmt13 ~]# pulp-admin repo download --repo-id zoo
+----------------------------------------------------------------------+
                      Downloading Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Download Repository Content
[=                                                 ] 3%
1 of 32 items
... failed

Task Succeeded

#5 Updated by pthomas@redhat.com over 3 years ago

I believe this is new in 2.11

This could be related
https://pulp.plan.io/issues/2471
https://pulp.plan.io/issues/2458

#6 Updated by pthomas@redhat.com over 3 years ago

Restarting pulp_streamer seems to have resolved the issue in my case

[root@mgmt13 ~]# service pulp_streamer restart
Restarting pulp streamer
Stopping pulp_streamer... OK
Starting pulp_streamer...
/usr/lib/python2.6/site-packages/pulp/server/db/connection.py:159: DeprecationWarning: add_son_manipulator is deprecated
  _DATABASE.add_son_manipulator(NamespaceInjector())
/usr/lib/python2.6/site-packages/pulp/server/db/model/base.py:96: DeprecationWarning: ensure_index is deprecated. Use create_index instead.
  unique=unique, background=True)
OK
[root@mgmt13 ~]# service pulp_streamer status
pulp_streamer (pid 5391) is running.
[root@mgmt13 ~]#
[root@mgmt13 ~]#
[root@mgmt13 ~]# pulp-admin rpm repo sync run --repo-id zoo
+----------------------------------------------------------------------+
                     Synchronizing Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[\]
... completed

Downloading repository content...
[-]
[==================================================] 100%
RPMs:       0/0 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Cleaning duplicate packages...
[-]
... completed

Task Succeeded

Task Succeeded

[root@mgmt13 ~]# pulp-admin repo download --repo-id zoo
+----------------------------------------------------------------------+
                      Downloading Repository [zoo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Download Repository Content
[==================================================] 100%
32 of 32 items
... completed

Task Succeeded

#7 Updated by mhrivnak over 3 years ago

We discussed on IRC that this could potentially be explained by an upgrade where the streamer did not get stopped before the upgrade. If a < 2.10 streamer was running with a >=2.10 pulp, this failure would be expected.

@preethi indicated that restarting the streamer solved the problem for her. We are waiting for more investigation about whether that was the root cause.

#8 Updated by pthomas@redhat.com over 3 years ago

Looking at upgrade job results, looks like we are not stop/starting pulp_streamer for upgrade.

TASK [pulp-upgrade : Stop services] ********************************************
changed: [localhost] => (item=httpd)
changed: [localhost] => (item=pulp_workers)
changed: [localhost] => (item=pulp_celerybeat)
changed: [localhost] => (item=pulp_resource_manager)

TASK [pulp-upgrade : Clean all package cache] **********************************
changed: [localhost]
 [WARNING]: Consider using yum module rather than running yum

TASK [pulp-upgrade : Update packages] ******************************************
changed: [localhost]

TASK [pulp-upgrade : Run pulp-manage-db] ***************************************
changed: [localhost]
 [WARNING]: Consider using 'become', 'become_method', and 'become_user' rather
than running sudo

TASK [pulp-upgrade : Run daemon reload] ****************************************
changed: [localhost]

TASK [pulp-upgrade : Start services] *******************************************
changed: [localhost] => (item=httpd)
changed: [localhost] => (item=pulp_workers)
changed: [localhost] => (item=pulp_celerybeat)
changed: [localhost] => (item=pulp_resource_manager)

#9 Updated by elyezer over 3 years ago

mhrivnak wrote:

We discussed on IRC that this could potentially be explained by an upgrade where the streamer did not get stopped before the upgrade. If a < 2.10 streamer was running with a >=2.10 pulp, this failure would be expected.

In fact the pulp_streamer was not being stopped and started on the upgrade playbook. I have updated the upgrade playbook, check the PR [1] for more information.

Also I have restarted pulp_streamer and run all lazy_sync Pulp Smash tests and no 500 was raised anymore.

[1] https://github.com/pulp/pulp_packaging/pull/262

#10 Updated by elyezer over 3 years ago

My suggestion then is to provide some sort of documentation on the release notes since the upgrade instructions usually state:

> $ sudo systemctl stop httpd pulp_workers pulp_resource_manager pulp_celerybeat
> $ sudo yum upgrade
> $ sudo -u apache pulp-manage-db
> $ sudo systemctl start httpd pulp_workers pulp_resource_manager pulp_celerybeat

Making it clear that pulp_streamer must be restarted will help users avoid the above issue.

#11 Updated by bmbouter over 3 years ago

Repurposing this bug to track the release note changes needed I think would make sense. If so, please retitle it, update the body, consider setting Tags.

#12 Updated by elyezer over 3 years ago

  • Subject changed from Downloading a RPM synced with different download_policies raises 500 Internal Server Error to Add documentation about the need of restart pulp_streamer when upgrading to Pulp 2.11 from old versions
  • Description updated (diff)
  • Priority changed from Urgent to High
  • Severity changed from 3. High to 2. Medium
  • Tags 2.11, Documentation, Easy Fix, Known Issue for Release Notes added

#13 Updated by bmbouter over 3 years ago

  • Tags deleted (2.11, Documentation, Easy Fix)

I'm removing the 2.11 tag since that is defunct. I can see why you would set it, it seems so appropriate. The 2.11 tag needs to be deleted really.

Since this is an all documentation fix, rather than having the release engineer create a known issue section of the release notes for it, they can merge in a release notes fix prior to GA. Any of us can prepare that PR as a commit off of the latest 2.11 beta tag so the release engineer would just merge it. We need an ack from the release engineer for 2.11 though before removing the "Known Issues for Release Notes" tag.

#14 Updated by elyezer over 3 years ago

  • Description updated (diff)

#15 Updated by bmbouter over 3 years ago

  • Status changed from NEW to POST
  • Assignee set to bmbouter

#16 Updated by bmbouter over 3 years ago

  • Status changed from POST to MODIFIED

#17 Updated by semyers over 3 years ago

  • Platform Release set to 2.11.0

#18 Updated by semyers over 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#19 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#20 Updated by bmbouter 2 months ago

  • Tags deleted (Known Issue for Release Notes)

Please register to edit this issue

Also available in: Atom PDF