Project

Profile

Help

Issue #2471

Repo download fails for drpm

Added by pthomas@redhat.com almost 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Downloading drpm for repos that has on-demand download policy fails

Steps to reproduce

1. Create a repo with drpm content with on-demand policy
2. Sync the repo
3. run repo download

#pulp-admin rpm repo create --repo-id drpm --feed https://repos.fedorapeople.org/pulp/pulp/fixtures/drpm-signed/  --download-policy on_demand 
Successfully created repository [drpm]

# pulp-admin rpm repo sync run --repo-id drpm
+----------------------------------------------------------------------+
                    Synchronizing Repository [drpm]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       5/5 items
Delta RPMs: 4/4 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Cleaning duplicate packages...
[-]
... completed

Task Succeeded

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
5 of 5 items
... completed

Publishing Delta RPMs
[==================================================] 100%
4 of 4 items
... completed

Publishing Errata
[-]
... completed

Publishing Comps file
[-]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Generating HTML files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

# pulp-admin repo download --repo-id drpm
+----------------------------------------------------------------------+
                     Downloading Repository [drpm]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Download Repository Content
[===========                                       ] 22%
2 of 9 items
... failed

Task Succeeded
 
# rpm -qa |grep pulp |sort
pulp-admin-client-2.11.0-0.4.beta.el7.noarch
pulp-docker-admin-extensions-2.2.0-0.2.beta.el7.noarch
pulp-docker-plugins-2.2.0-0.2.beta.el7.noarch
pulp-ostree-admin-extensions-1.2.0-0.3.beta.el7.noarch
pulp-ostree-plugins-1.2.0-0.3.beta.el7.noarch
pulp-puppet-admin-extensions-2.11.0-0.4.beta.el7.noarch
pulp-puppet-plugins-2.11.0-0.4.beta.el7.noarch
pulp-python-admin-extensions-1.1.3-1.el7.noarch
pulp-python-plugins-1.1.3-1.el7.noarch
pulp-rpm-admin-extensions-2.11.0-0.4.beta.el7.noarch
pulp-rpm-plugins-2.11.0-0.4.beta.el7.noarch
pulp-selinux-2.11.0-0.4.beta.el7.noarch
pulp-server-2.11.0-0.4.beta.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-kombu-3.0.33-6.pulp.el7.noarch
python-pulp-bindings-2.11.0-0.4.beta.el7.noarch
python-pulp-client-lib-2.11.0-0.4.beta.el7.noarch
python-pulp-common-2.11.0-0.4.beta.el7.noarch
python-pulp-docker-common-2.2.0-0.2.beta.el7.noarch
python-pulp-oid_validation-2.11.0-0.4.beta.el7.noarch
python-pulp-ostree-common-1.2.0-0.3.beta.el7.noarch
python-pulp-puppet-common-2.11.0-0.4.beta.el7.noarch
python-pulp-python-common-1.1.3-1.el7.noarch
python-pulp-repoauth-2.11.0-0.4.beta.el7.noarch
python-pulp-rpm-common-2.11.0-0.4.beta.el7.noarch
python-pulp-streamer-2.11.0-0.4.beta.el7.noarch

Related issues

Is duplicate of Pulp - Issue #1781: Files ending in .gz are delivered with incorrect content headersCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by pthomas@redhat.com almost 4 years ago

Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16259]: celery.worker.strategy:INFO: Received task: pulp.server.controllers.repository.download_repo[3de80f07-22f8-4e74-a1b5-0ded8150de5b]
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): cloud-qe-22.idmqe.lab.eng.bos.redhat.com
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (2): cloud-qe-22.idmqe.lab.eng.bos.redhat.com
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (3): cloud-qe-22.idmqe.lab.eng.bos.redhat.com
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (4): cloud-qe-22.idmqe.lab.eng.bos.redhat.com
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320) ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320) Traceback (most recent call last):
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 290, in _fetch
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320)     for chunk in chunks:
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320)   File "/usr/lib/python2.7/site-packages/requests/models.py", line 661, in generate
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320)     raise ContentDecodingError(e)
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-12320) ContentDecodingError: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: pulp.server.controllers.repository:INFO: Download of /var/lib/pulp/content/units/drpm/bb/4d619faa45751232cf5b441539210eb0086581f1448001301a97bae98eeb29/drpms/test-alpha-1.1-1_1.1-2.noarch.drpm failed: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',)).
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912) ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912) Traceback (most recent call last):
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 290, in _fetch
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912)     for chunk in chunks:
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912)   File "/usr/lib/python2.7/site-packages/requests/models.py", line 661, in generate
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912)     raise ContentDecodingError(e)
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-26912) ContentDecodingError: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: pulp.server.controllers.repository:INFO: Download of /var/lib/pulp/content/units/drpm/8b/4e9fb2cb4bf974fe1dbd56de44bb1054f358f8c69142e29b2b16785a210be1/drpms/test-alpha-1.1-2_1.1-3.noarch.drpm failed: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',)).
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200) ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200) Traceback (most recent call last):
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 290, in _fetch
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200)     for chunk in chunks:
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200)   File "/usr/lib/python2.7/site-packages/requests/models.py", line 661, in generate
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200)     raise ContentDecodingError(e)
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-91200) ContentDecodingError: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: pulp.server.controllers.repository:INFO: Download of /var/lib/pulp/content/units/drpm/0b/3deb5696042324c1ef2e020aa7943929b2d71bd4913b5f79571c2ca7f949a7/drpms/test-alpha-1.1-3_1.2-1.noarch.drpm failed: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',)).
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208) ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208) Traceback (most recent call last):
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208)   File "/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py", line 290, in _fetch
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208)     for chunk in chunks:
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208)   File "/usr/lib/python2.7/site-packages/requests/models.py", line 661, in generate
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208)     raise ContentDecodingError(e)
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: nectar.downloaders.threaded:ERROR: (16351-34208) ContentDecodingError: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',))
Dec 05 13:03:22 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16351]: pulp.server.controllers.repository:INFO: Download of /var/lib/pulp/content/units/drpm/b6/9279dfdb3e289ac6448a68ca17ba809bb10dc77384e862d8bb91016974e50b/drpms/test-alpha-1.2-1_1.2-2.noarch.drpm failed: ('Received response with content-encoding: gzip, but failed to decode it.', error('Error -3 while decompressing: incorrect header check',)).
Dec 05 13:03:23 cloud-qe-22.idmqe.lab.eng.bos.redhat.com pulp[16259]: celery.worker.job:INFO: Task pulp.server.controllers.repository.download_repo[3de80f07-22f8-4e74-a1b5-0ded8150de5b] succeeded in 1.03288896s: None

#2 Updated by mhrivnak almost 4 years ago

I suspect this is a duplicate of https://pulp.plan.io/issues/1781

Trying this workaround would confirm it:

https://pulp.plan.io/issues/1781#note-15

#3 Updated by pthomas@redhat.com almost 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

I tested the workaround with the issue and it worked. Closing it as duplicate.

#4 Updated by pthomas@redhat.com almost 4 years ago

  • Is duplicate of Issue #1781: Files ending in .gz are delivered with incorrect content headers added

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF