Project

Profile

Help

Issue #2465

closed

Vagrant env does not install goferd systemd file

Added by bmbouter almost 6 years ago. Updated over 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Using vanilla vagrant file from pulp/devel at commit fd7eca999983440b03d17f6564919e1744d0d16f (current HEAD of master) after running vagrant up everything works except that goferd is not installed.

This issue exists even if I check out different versions of Pulp (2.9-dev or master) for example, so I think the issue is with the Vagrant playbook at that commit ^.

goferd is installed:

[vagrant@dev ~]$ rpm -qa | grep gofer
python-gofer-qpid-2.9.2-1.fc24.noarch
python-gofer-2.9.2-1.fc24.noarch

The unit files are not loaded. pstatus says:

‚óŹ goferd.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
Actions #1

Updated by jortel@redhat.com almost 6 years ago

The python-gofer RPM is just the gofer library. The goferd (agent) daemon and associated systemd unit is installed by the gofer RPM.

Actions #2

Updated by bizhang almost 6 years ago

  • Triaged changed from No to Yes

Added by dkliban@redhat.com almost 6 years ago

Revision 34e98066

Problem: gofer package not installed on Vagrant box

Solution: expand the dev role to install gofer package

closes #2465 https://pulp.plan.io/issues/2465

Actions #3

Updated by dkliban@redhat.com almost 6 years ago

  • Status changed from NEW to CLOSED - CURRENTRELEASE
Actions #4

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF