Project

Profile

Help

Task #2373

Planning on how to support global importer settings

Added by jortel@redhat.com about 3 years ago. Updated 7 months ago.

Status:
CLOSED - COMPLETE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Planning on how to support global importer settings in pulp3 based on this pulp2 story https://pulp.plan.io/issues/1251.

Things to consider:
  • Are global settings used for importer creation only (Like a template)?
  • If not for creation only - what is expected behavior when the global setting changes? Applied to all existing importers?
  • Which settings can be global (just credentials, proxy etc)? Limited to just standard settings to also custom settings (fields) added by plugin importer models?
  • Are globals stored in the DB?
  • How are globals associated (applied) to specific importers? Statically? Dynamically (part of sync call)?
  • Could this be address with mass update instead? For example: update proxy_url on all/filtered set of importers?

Related issues

Related to Pulp - Story #3108: As a user, I can manage Download Profiles and associate them with Importers NEW Actions

History

#1 Updated by bmbouter about 3 years ago

I don't have opinions on all of these choices, but here are a few first thoughts.

I see the use case as a user wanting to change their proxy config and they need everything now to use the new settings. Based on that understanding, I think we should avoid the templates approach and let the global settings be able to be changed once and take effect for all exiting importers.

Whitelisting a very limited set of fields that this can be done for I think would be safer than having a fully generalized version.

Keeping the config out of the DB will allow us to build less in terms of CRUD operations for that global config. +1 to having them just be a special file on the filesystem.

I'll have to think more about the other questions.

#2 Updated by mhrivnak about 3 years ago

I've considered the idea of something like a "Download Profile" that could be defined separately from an importer, given a meaningful name, and associated with many importers. Examples a user might create:

  • Local
  • Proxy to Internet
  • Proxy to Secret Internal Network

Excluding authentication, users likely don't want or need to have many variations of download settings. They want to use the same settings everywhere, with possibly a small number of use-case-based variations.

It would be good to get feedback on this general concept from users. I also wonder if katello is already doing something along these lines, managing profiles on top of pulp's settings.

#3 Updated by bmbouter about 3 years ago

+1 to @mhrivnak 's Download Profile idea.

#4 Updated by jortel@redhat.com over 2 years ago

+1. May want to name it an Importer Profile as it may not necessarily be restricted to downloading attributes.

#5 Updated by mhrivnak over 2 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#6 Updated by mhrivnak over 2 years ago

  • Sprint/Milestone set to 40

#7 Updated by mhrivnak over 2 years ago

  • Sprint/Milestone changed from 40 to 41

#8 Updated by mhrivnak over 2 years ago

  • Sprint/Milestone deleted (41)

#9 Updated by mhrivnak about 2 years ago

  • Sprint/Milestone set to 45

#10 Updated by mhrivnak about 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to mhrivnak

#11 Updated by jortel@redhat.com about 2 years ago

  • Sprint/Milestone changed from 45 to 46

#12 Updated by mhrivnak about 2 years ago

  • Related to Story #3108: As a user, I can manage Download Profiles and associate them with Importers added

#14 Updated by mhrivnak about 2 years ago

  • Sprint/Milestone changed from 46 to 47

#15 Updated by rchan about 2 years ago

  • Sprint/Milestone changed from 47 to 48

#16 Updated by daviddavis about 2 years ago

  • Tags Pulp 3 MVP added

#17 Updated by dkliban@redhat.com almost 2 years ago

  • Sprint/Milestone deleted (48)
  • Tags deleted (Pulp 3 MVP)

#18 Updated by mhrivnak almost 2 years ago

  • Assignee deleted (mhrivnak)

#19 Updated by bmbouter almost 2 years ago

  • Status changed from POST to CLOSED - COMPLETE

This planning task looks complete so I'm closing it as done. We aren't generating followup stories currently since it's not part of the immediate MVP work.

#20 Updated by daviddavis 7 months ago

  • Sprint/Milestone set to 3.0

#21 Updated by bmbouter 7 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF