Project

Profile

Help

Story #225

closed

[RFE] Support to list details information about one specific pulp repo

Added by szhou@redhat.com almost 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
2.7.0
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1077506 ++

Description of problem:

Description of problem:

  1. pulp-admin rpm repo list --details
    Now above command can list all existing pulp repos details, while no way to get details for only one specific pulp repo.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

--- Additional comment from at 04/03/2014 14:05:48 ---

+1 to this RFE. I frequently need to review the detailed configuration for an individual repo (either so I can determine if something needs to be changed, or to configure a new repo with similar settings), and it is tedious to have to wade through the details for all repos (including the SSL certs and GPG keys!) when I am only interested in one.

--- Additional comment from at 09/29/2014 18:38:20 ---

+1! (as Christina said)

--- Additional comment from at 11/17/2014 20:06:20 ---

Just to say, I currently work around this by using sed to remove unwanted repos.

eg.

pulp-admin repo list --details | sed -n '/repo-name/,/^$/p'

n turns off printing by default
/repo-name/ <
what I'm looking for
/,/ match between
/^$/ <- blank line
/p <- print (since -n turned it off)

Not a solution, just a work around.

--- Additional comment from at 12/01/2014 16:35:36 ---

https://github.com/pulp/pulp/pull/1377

Also available in: Atom PDF