Project

Profile

Help

Issue #1928

Publish should be operational if override config values were specified

Added by Ichimonji10 over 5 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
2.9.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 3
Quarter:

Description

Let's say that you create a Pulp repository with a feed and sync it. You should then be able to make the repository content available in at least the following ways:

  • Publish the repository contents to a directory.
  • Publish the repository contents so they're accessible via HTTP.

If you take the following series of steps, you'll succeed:

1. Create a distributor.
2. Publish the repository to one kind of location (e.g. a directory) with that distributor.
3. Create a second distributor.
4. Publish the repository to the other kind of location (e.g. via HTTP) with the second distributor.

If you take the following series of steps, you'll fail:

1. Create a distributor.
2. Publish the repository to one kind of location (e.g. a directory) with that distributor.
3. Publish the repository to the other kind of location (e.g. via HTTP) with the same distributor.

Pulp doesn't complain at all when the second publish occurs, and no errors appear in the logs. Instead, the second publication just doesn't happen. This doesn't make sense. One of the following should occur:

  • Pulp should return an HTTP 3XX response when the second publication request is received.
  • Pulp should successfully complete the second publish.

This bug has been reproduced on Pulp 2.8.3 and master (2.9.0). This bug has been reproduced with RPM repositories, and it's unclear whether this same issue applies to other content types.

Issue consists in the fact that second publish does not occur as it is considered as no-op.
No-op logic should be changed and added the case when in override_config something was specified.

Associated revisions

Revision 34a9ba77 View on GitHub
Added by ipanova@redhat.com over 5 years ago

Publish should be operational if override config values were specified

closes #1928 https://pulp.plan.io/issues/1928

Revision 34a9ba77 View on GitHub
Added by ipanova@redhat.com over 5 years ago

Publish should be operational if override config values were specified

closes #1928 https://pulp.plan.io/issues/1928

Revision 4de59d4c View on GitHub
Added by ipanova@redhat.com over 5 years ago

Publish should be operational if override config values were specified

closes #1928 https://pulp.plan.io/issues/1928

Another corner case.

Revision 4de59d4c View on GitHub
Added by ipanova@redhat.com over 5 years ago

Publish should be operational if override config values were specified

closes #1928 https://pulp.plan.io/issues/1928

Another corner case.

History

#2 Updated by Ichimonji10 over 5 years ago

This pull request updates the test case to accommodate this bug: https://github.com/PulpQE/pulp-smash/pull/259

The bug report above states that "Pulp should return an HTTP 3XX response when the second publication request is received." This is incorrect. The sentence should say "HTTP 4XX."

#3 Updated by ipanova@redhat.com over 5 years ago

export_distributor is responsible for publishing content into a directory meanwhile yum_distributor is responsible to publish content via http/https, so that is logical that export_distributor will not work for content publish via http.

So i followed your steps and by having just export_distributor i was able to successfully export content into a specific dir, or into an ISO which is served via http.
When i tried to make a regular publish, pulp obviously complained that it misses the distributor that is responsible for that work.

$ pulp-admin rpm repo publish run --repo-id 123 

+----------------------------------------------------------------------+
                      Publishing Repository [123]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Task Failed

Missing resource(s): repo_id=123, distributor_id=yum_distributor

With that said, i think we should close it as not a bug as by design we have specific distributor responsible for specific things. Or maybe i don't follow something in the bug description.

#4 Updated by ipanova@redhat.com over 5 years ago

After some chat and details clarification with Jeremy, we have an issue that appeared due to implementation of no-op publish feature. I will update the description of the issue accordingly.

#5 Updated by mhrivnak over 5 years ago

  • Priority changed from Normal to High
  • Platform Release set to 2.8.4
  • Triaged changed from No to Yes

#6 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#7 Updated by ipanova@redhat.com over 5 years ago

  • Project changed from RPM Support to Pulp
  • Description updated (diff)

#8 Updated by Ichimonji10 over 5 years ago

I was mistaken when I stated that this bug affects Pulp 2.8.3 and master (2.9). That's untrue. This bug only affects Pulp 2.9.

#9 Updated by ipanova@redhat.com over 5 years ago

  • Sprint/Milestone set to 21
  • Platform Release changed from 2.8.4 to 2.9.0

#10 Updated by ipanova@redhat.com over 5 years ago

  • Subject changed from Cannot reuse distributor for directory and web publish to Publish should be operational if override config values were specified

#11 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from ASSIGNED to POST

#12 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#13 Updated by Ichimonji10 over 5 years ago

  • Status changed from MODIFIED to ASSIGNED

The bug described by this issue is still failing, and the symptoms are exactly the same. After discussing this with ipanova, we've figured out that there's a corner case in Pulp that's not been fixed yet. Setting back to ASSIGNED.

#14 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from ASSIGNED to MODIFIED

#15 Updated by semyers over 5 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#17 Updated by bmbouter almost 4 years ago

  • Sprint set to Sprint 3

#18 Updated by bmbouter almost 4 years ago

  • Sprint/Milestone deleted (21)

#19 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF