Project

Profile

Help

Issue #1926

package without epoch in the erratum pkglist is not handled correctly during publish

Added by ttereshc over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.8.3
Platform Release:
2.9.3
OS:
Triaged:
Yes
Groomed:
Yes
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 7
Quarter:

Description

Create repo with feed https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm/ and sync/publish it.
Since our demo repo does not contain `epoch` for packages in updateinfo.xml, there will be a `null` value for epoch in the erratum pkglist in the database.
This will cause a DB query which checks the presence of the particular rpm in the repo to be wrong and thus you will observe no packages in the updateinfo.xml after publish.


Related issues

Related to RPM Support - Issue #833: older errata units may have 'null' in database for pkglist package epochCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Has duplicate RPM Support - Issue #2217: updateinfo.xml is not generated with any packagesCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 250c100e View on GitHub
Added by ttereshc over 5 years ago

Fix package filtering for errata when no epoch is specified

closes #1926 https://pulp.plan.io/issues/1926

History

#1 Updated by ttereshc over 5 years ago

Should the epoch attribute be always present in the erratum pkglist for each package? If so, it is a problem of demo repo and not a bug in Pulp.
Or should we handle this case during sync/upload? or during publish?

#2 Updated by mhrivnak over 5 years ago

  • Groomed changed from No to Yes

I was not able to find any old repos where the epoch is an empty string.

#3 Updated by dkliban@redhat.com over 5 years ago

  • Subject changed from package without epoch in the erratum pkglist is not handled correctly during publish to fixtures repo is missing 'epoch' in the erratum pkglist
  • Triaged changed from No to Yes

We should fix the fixtures repository as part of this issue

#4 Updated by jsherril@redhat.com over 5 years ago

This can happen in the wild: https://pulp.plan.io/issues/833

#5 Updated by ttereshc over 5 years ago

  • Subject changed from fixtures repo is missing 'epoch' in the erratum pkglist to package without epoch in the erratum pkglist is not handled correctly during publish
  • Status changed from NEW to POST
  • Assignee set to ttereshc

#6 Updated by ttereshc over 5 years ago

  • Has duplicate Issue #2217: updateinfo.xml is not generated with any packages added

#7 Updated by ttereshc over 5 years ago

  • Related to Issue #833: older errata units may have 'null' in database for pkglist package epoch added

#8 Updated by ttereshc over 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#9 Updated by ttereshc over 5 years ago

  • Platform Release set to 2.9.3

#10 Updated by ttereshc over 5 years ago

  • Sprint/Milestone set to 25

#11 Updated by semyers over 5 years ago

  • Status changed from MODIFIED to 5

#12 Updated by pthomas@redhat.com about 5 years ago

  • Status changed from 5 to 6

verified
1. synced and published repo with https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm/
2. Checked the updateinfo.xml to make sure that the packages are present

#13 Updated by semyers about 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#15 Updated by bmbouter over 3 years ago

  • Sprint set to Sprint 7

#16 Updated by bmbouter over 3 years ago

  • Sprint/Milestone deleted (25)

#17 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF