Project

Profile

Help

Issue #1809

python 2.6 incompatibility during set_importer

Added by mhrivnak over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
2.8.3
OS:
RHEL 6
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Sprint 1
Quarter:

Description

This traceback is occurring on el6 (python 2.6) when importer_controller.set_importer() is called.

Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184) Exception adding importer to repo [Default_Organization-zoo-zoo]; the repo will be deleted
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184) Traceback (most recent call last):
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 410, in create_repo
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     importer_controller.set_importer(repo_id, importer_type_id, importer_repo_plugin_config)
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/celery/local.py", line 167, in <lambda>
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     __call__ = lambda x, *a, **kw: x._get_current_object()(*a, **kw)
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 473, in __call__
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     return super(Task, self).__call__(*args, **kwargs)
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 103, in __call__
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     return super(PulpTask, self).__call__(*args, **kwargs)
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/celery/app/task.py", line 420, in __call__
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     return self.run(*args, **kwargs)
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/importer.py", line 96, in set_importer
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     importer.save()
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 279, in save
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     (importer_constants.KEY_SSL_CA_CERT, self.tls_ca_cert_path),
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 292, in tls_ca_cert_path
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     return os.path.join(self._pki_path, 'ca.crt')
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 330, in _pki_path
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     return os.path.join(self._local_storage_path, 'pki')
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 321, in _local_storage_path
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184)     '{}-{}'.format(self.repo_id, self.importer_type_id))
Apr  4 11:01:26 mgmt12 pulp: pulp.server.controllers.repository:ERROR: (24007-85184) ValueError: zero length field name in format

Associated revisions

Revision 1503f277 View on GitHub
Added by Austin Macdonald over 4 years ago

Fix string format for python 2.6 compat

closes #1809

Revision 1503f277 View on GitHub
Added by Austin Macdonald over 4 years ago

Fix string format for python 2.6 compat

closes #1809

History

#1 Updated by amacdona@redhat.com over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to amacdona@redhat.com

#2 Updated by amacdona@redhat.com over 4 years ago

  • Status changed from ASSIGNED to POST

#3 Updated by Anonymous over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#4 Updated by semyers over 4 years ago

  • Platform Release changed from 2.8.2 to 2.8.3

#6 Updated by Ichimonji10 over 4 years ago

Is there a procedure for reproducing this bug as an end user?

#7 Updated by amacdona@redhat.com over 4 years ago

I don't think this particular bug would be deserving of a regression test because it is no more likely that we would recreate this error here than any of the places we do string processing. This made it into the code in the first place because a test error was being hidden by other problems with the unit tests. I think that the best we can do (or at least the most we should do) is simply run pulp-smash against a RHEL 6 machine running pulp.

#8 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#9 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from 5 to 6

Moving to verified as per comment #7
pulp-smash tests against rhel6 have passed.

#10 Updated by semyers over 4 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 1

#13 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (19)

#14 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF