Project

Profile

Help

Issue #1610

added updated and removed count all 0 on first sync

Added by jsherril@redhat.com almost 5 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
2.8.0
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When syncing a yum repo, the 'results' hash which contains:

"added_count"=>0,
"removed_count"=>0,
"updated_count"=>0,

is all 0 even if units are synced.

Steps to reproduce:
a) create a yum repo pointing to some feed with at least one package
b) sync the repo
c) examine the task output:

  "result"=>
       {"result"=>"success",
        "importer_id"=>{"$oid"=>"56af754a0555153b7f89d879"},
        "exception"=>nil,
        "repo_id"=>"Default_Organization-tester-tester",
        "traceback"=>nil,
        "started"=>"2016-02-01T15:10:37Z",
        "_ns"=>"repo_sync_results",
        "completed"=>"2016-02-01T15:11:20Z",
        "importer_type_id"=>"yum_importer",
        "error_message"=>nil,
        "summary"=>
         {"content"=>{"state"=>"FINISHED"},
          "comps"=>{"state"=>"FINISHED"},
          "distribution"=>{"state"=>"FINISHED"},
          "errata"=>{"state"=>"FINISHED"},
          "metadata"=>{"state"=>"FINISHED"}},
        "added_count"=>0,
        "removed_count"=>0,
        "updated_count"=>0,
        "id"=>"56af75980555153c4bd1774e",
        "details"=>
         {"content"=>
           {"size_total"=>103477800,
            "items_left"=>0,
            "items_total"=>367,
            "state"=>"FINISHED",
            "size_left"=>0,
            "details"=>
             {"rpm_total"=>367,
              "rpm_done"=>367,
              "drpm_total"=>0,
              "drpm_done"=>0},
            "error_details"=>[]},
          "comps"=>{"state"=>"FINISHED"},
          "distribution"=>
           {"items_total"=>0,
            "state"=>"FINISHED",
            "error_details"=>[],
            "items_left"=>0},
          "errata"=>{"state"=>"FINISHED"},
          "metadata"=>{"state"=>"FINISHED"}}},
      "error"=>nil,
      "_id"=>{"$oid"=>"56af756ddeeba77d7fad3d51"},
      "id"=>"56af756ddeeba77d7fad3d51"},

Related issues

Related to RPM Support - Issue #1621: sync with "remove-missing" failing.CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 36ba7f5f View on GitHub
Added by Austin Macdonald almost 5 years ago

fix added, updated, and removed counts for mongoengine converted plugins

closes #1610

Revision 36ba7f5f View on GitHub
Added by Austin Macdonald almost 5 years ago

fix added, updated, and removed counts for mongoengine converted plugins

closes #1610

History

#1 Updated by jsherril@redhat.com almost 5 years ago

  • Subject changed from added updated and removed count all 0 on first sycn to added updated and removed count all 0 on first sync

#2 Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from NEW to ASSIGNED

#3 Updated by bmbouter almost 5 years ago

  • Assignee set to amacdona@redhat.com

#4 Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from ASSIGNED to POST

https://github.com/pulp/pulp/pull/2389

Because we are no longer using the conduit to do these actions, we needed to implement this differently. I was able to confirm that added_count and updated_count work as expected, but removed_count was not possible to to test because of https://pulp.plan.io/issues/1621. I will relate the issues and comment on #1621 that the removed_count field of the task result should be inspected for syncs that remove content.

#5 Updated by amacdona@redhat.com almost 5 years ago

  • Platform Release set to 2.8.0

#6 Updated by amacdona@redhat.com almost 5 years ago

  • Related to Issue #1621: sync with "remove-missing" failing. added

#7 Updated by pthomas@redhat.com almost 5 years ago

Will test this once 1621 is fixed !

#8 Updated by Anonymous almost 5 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#9 Updated by jortel@redhat.com almost 5 years ago

  • Triaged changed from No to Yes

#10 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from MODIFIED to 5

#11 Updated by dkliban@redhat.com almost 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF