Project

Profile

Help

Issue #1584

closed

400 error when trying to kick off applicability regeneration

Added by dkliban@redhat.com about 7 years ago. Updated almost 4 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.0
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

My criteria.json file looks like this:

{
 "repo_criteria": {
 "filters":{ "id": {"$in":["ideate"]}}
 }
}
$ http --json --verify no --auth admin:admin POST "https://localhost/pulp/api/v2/repositories/actions/content/regenerate_applicability/" < criteria.json 
HTTP/1.1 400 BAD REQUEST
Connection: close
Content-Encoding: utf-8
Content-Length: 374
Content-Type: application/json; charset=utf-8
Date: Tue, 26 Jan 2016 14:28:25 GMT
Server: Apache/2.4.18 (Fedora) OpenSSL/1.0.2e-fips mod_wsgi/4.4.8 Python/2.7.10

{
    "_href": "/pulp/api/v2/repositories/actions/content/regenerate_applicability/", 
    "args": [], 
    "error": {
        "code": "PLP1015", 
        "data": {
            "data_type": "dict"
        }, 
        "description": "The JSON data must be of type 'dict'.", 
        "sub_errors": []
    }, 
    "error_message": "The JSON data must be of type 'dict'.", 
    "exception": null, 
    "http_request_method": "POST", 
    "http_status": 400, 
    "traceback": null
}

The exception is being raised here[0]. This is a regression as result of this[1] commit.

[0] https://github.com/pulp/pulp/blob/master/server/pulp/server/webservices/views/util.py#L125
[1] https://github.com/pulp/pulp/commit/75af2dd1113d47a282911c6a88b47a7f7d193dde

Also available in: Atom PDF