Project

Profile

Help

Issue #1399

Can't bind repo to pulp-consumer

Added by dkliban@redhat.com almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

It looks to me that even though pulp-consumer is reporting that the consumer is registered, the database is not being updated to reflect that information. As result you can't bind a repo to to the consumer.

sudo pulp-consumer -u admin -p admin register --consumer-id c1

Consumer [c1] successfully registered

pulp-consumer rpm bind --repo-id=zoo
The following resource(s) could not be found:

  c1 (login)

---------- ssl_access_log -------------

172.16.137.44 - - [07/Dec/2015:18:36:14 +0000] "POST /pulp/api/v2/consumers/ HTTP/1.1" 201 2502
172.16.137.44 - - [07/Dec/2015:18:36:14 +0000] "GET /pulp/static/rsa_pub.key HTTP/1.1" 200 451
172.16.137.44 - - [07/Dec/2015:18:36:15 +0000] "GET /pulp/api/v2/consumers/c1/ HTTP/1.1" 404 343

172.16.137.44 - - [07/Dec/2015:18:36:31 +0000] "POST /pulp/api/v2/consumers/c1/bindings/ HTTP/1.1" 404 353

Checklist

Associated revisions

Revision a81bb03e View on GitHub
Added by Jeremy Cline almost 6 years ago

The auth decorator no longer causes a 404s for consumers.

It also no longer causes a 404 for missing users, which is an incorrect behaviour since this decorator is used on all views.

closes #1399

Revision a81bb03e View on GitHub
Added by Jeremy Cline almost 6 years ago

The auth decorator no longer causes a 404s for consumers.

It also no longer causes a 404 for missing users, which is an incorrect behaviour since this decorator is used on all views.

closes #1399

History

#1 Updated by dkliban@redhat.com almost 6 years ago

  • Platform Release set to 2.8.0

#2 Updated by mhrivnak almost 6 years ago

  • Checklist item Confirm if this affects 2.7.x added
  • Triaged changed from No to Yes

#3 Updated by jcline@redhat.com almost 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jcline@redhat.com

#4 Updated by jcline@redhat.com almost 6 years ago

  • Checklist item Confirm if this affects 2.7.x set to Done

I was unable to reproduce this on 2.7:

[vagrant@dev pulp]$ sudo pulp-consumer -v -u admin -p admin register --consumer-id c1
Consumer [c1] successfully registered

> db.consumers.find()
{ "_id" : ObjectId("5670629de779897c559d5552"), "display_name" : "c1", "description" : null, "_ns" : "consumers", "notes" : {  }, "rsa_pub" : "-----BEGIN PUBLIC KEY-----\nMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKC
AQEAzwqctfMGVIHIm9HxkVhX\nbqd7u5a1iiKVkBUoUptbsnO1TE4WJLSrw/ZLXcGA3HkCMdsu9THQyQDz9VScl5Wt\n0Ch2velGeRqJXGx3QucXbdgLeMVeVgeNirSow5QFuPKMf/maLd+0sUkFyF02wVDQ\nh1N73B5N0XZxVniI/SW4diDkXbvyTp3eesvcXVXAk9cm2BcIwazmM
isqmmE0IQkb\nUDSv4hhpoWRMHKYTDXjLF8mdtgkRS8QQ+HkcuuAe1FXpd4Wi/KSziqA0iI+qdzGd\nLx7zXO1zFBE2N4//sl9T8nnxhyYyanXyzhx9Z6Mc/OgHZqsNlH4vTqDgWXQ+woXk\newIDAP//\n-----END PUBLIC KEY-----\n", "capabilities" : {  }, "id"
 : "c1" }

[vagrant@dev pulp]$ pulp-consumer rpm bind --repo-id=zoo
Bind tasks successfully created:

Task Id: 4e30b604-d1f3-4a7c-b945-99f54d8bfe57

> db.consumer_bindings.find()
{ "_id" : ObjectId("56706321e779897c569ed33e"), "notify_agent" : true, "repo_id" : "zoo", "consumer_id" : "c1", "_ns" : "consumer_bindings", "deleted" : false, "consumer_actions" : [ { "status" : "pending", "act
ion" : "bind", "id" : "4e30b604-d1f3-4a7c-b945-99f54d8bfe57", "timestamp" : 1450205985.527415 } ], "binding_config" : {  }, "distributor_id" : "yum_distributor", "id" : "56706321e779897c569ed33e" }

#5 Updated by jcline@redhat.com almost 6 years ago

  • Assignee deleted (jcline@redhat.com)

On master, this appears to work if you do 'pulp-consumer -u <user> -p <password> rpm bind --repo-id=zoo'.

#6 Updated by jcline@redhat.com almost 6 years ago

  • Assignee set to jcline@redhat.com

#7 Updated by jcline@redhat.com almost 6 years ago

  • Status changed from ASSIGNED to POST

#8 Updated by Anonymous almost 6 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#9 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from MODIFIED to 5

#10 Updated by pthomas@redhat.com over 5 years ago

  • Status changed from 5 to 6

verified
Repo bind & Installing packages works

[root@mgmt5 ~]# pulp-admin consumer list --details
--------------------------------------------------------------------
Consumers
--------------------------------------------------------------------

Id: starfish
Display Name: starfish
Bindings:
Confirmed: upload
Unconfirmed:
Capabilities:
Description: None
Notes:
Rsa Pub: -----BEGIN PUBLIC KEY-----
MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwo4DhVPRCFAgND6dnhGw
jCM06a/nqG5fMI7Juz6SbMBwoVBFYPZIc+52mPBXqQtzp0Ctwsjoh+J58X2q/Gc3
X0jbryq1eLhOd06ilDCXc7dlJgrqS8Vt2X/BByIe/O2LCPdlckAXnekdlwjnUO8h
RF3trkEFSALHa+8bwLNMw3aGI9aHcEtKGaAJHIGMj8BqfLtfiAYwgFlpnRIXkF4S
qlPoLHCdWfyq8bKhk6rBVkQ+JH7P9knyuFTFX5vl1GUVQIr+FxKEQlONW41TYFbC
vz9YsoeG+9u12kz2mUzqNwj6/ToTH+9a0C2MEVxt3RAfDlPOQnCT9QAfq9D9d7qj
JQIDAP// -----END PUBLIC KEY-----

Id: b43367d5-1a3a-4d94-8ffc-adffd0c7b44e
Display Name: b43367d5-1a3a-4d94-8ffc-adffd0c7b44e
Bindings:
Capabilities:
Description: None
Notes:
Rsa Pub: None

#11 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF