Project

Profile

Help

Task #1397

Nightly testing pipeline

Added by dkliban@redhat.com almost 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

We currently build our packages every night. We produce packages from all of our branches. This task outlines the work that needs to be done to test the packages on nightly basis using pulp-smash.

Nightly jobs pipeline will consist of the following:

- Build packages using each -dev branch and master branch and publish to fedorapeople.org/pulp/pulp/testing/automation directory.
- For each version of Pulp built in previous:
    - Reserve a jenkins node running a vanilla image of EL6, EL7, Fedora 22, Fedora 23.
    - Enable the testing repositories and update all packages (or not use "testing" repos if there are known issues)
    - Install Pulp from fedorapeople.org nightly repositories
    - Deploy pulp-smash on a node running Fedora 23 image
    - Run pulp-smash aginst Pulp

Currently all of our Jenkins node types have a lot of dependencies already installed on them to facilitate testing with unit tests. To do the kind of integration testing described above we should add very plain Jenkins nodes to our infrastructure. We already have Jenkins jobs that can deploy pulp-smash on a Fedora 23 node and run it against any hostname provided.


Checklist


Related issues

Is duplicate of Pulp - Task #1083: Configure Jenkins to auto-test stable pulp against "current fedoras" using -testing fedora repoCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jcline@redhat.com almost 5 years ago

For the sake of clarity, when you say "- Deploys Pulp 2.* stable on [platform] - testing repos enabled - and runs pulp-smash", you mean the fedora-updates-testing repository, correct?

#2 Updated by dkliban@redhat.com almost 5 years ago

That is correct ... that is what I meant by "Enable the testing repositories and update all packages" in the section above. The idea is to test packages that are coming down the pipeline and flag any that will cause a problem for Pulp.

I'll update the wording.

#3 Updated by bmbouter almost 5 years ago

This writeup can probably eliminate this one: https://pulp.plan.io/issues/1083

#4 Updated by dkliban@redhat.com almost 5 years ago

  • Checklist item Email eng-ops to get more RAM for our QEOS project added
  • Checklist item Configure nodepool to provide vanilla Fedora and EL nodes added
  • Checklist item Create jenkins jobs as yaml files in pulp_packaging added
  • Checklist item Create ability to disable use of "testing" repositories added
  • Description updated (diff)

#5 Updated by dkliban@redhat.com almost 5 years ago

  • Description updated (diff)

#6 Updated by dkliban@redhat.com almost 5 years ago

  • Checklist item Email eng-ops to get more RAM for our QEOS project set to Done
  • Checklist item Configure nodepool to provide vanilla Fedora and EL nodes set to Done

#7 Updated by dkliban@redhat.com over 3 years ago

  • Is duplicate of Task #1083: Configure Jenkins to auto-test stable pulp against "current fedoras" using -testing fedora repo added

#8 Updated by dkliban@redhat.com over 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#9 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF