Project

Profile

Help

Issue #1245

Pulp cannot be configured to connect to Qpid at 'localhost'

Added by bmbouter over 4 years ago. Updated 9 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
2.6.2 Beta
Platform Release:
2.7.0
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

When using a broker string in the the [tasks] section as follows, instead of connecting to 'localhost' it connects to '127.0.0.1'.

qpid://localhost:5671

I expect it to connect to localhost since that is specifically the hostname specified. This is an important difference if someone were to be using SSL cert verification and the cert's CN specified localhost.

Associated revisions

Revision 4c897619 View on GitHub
Added by bmbouter over 4 years ago

Upgrades kombu to 3.0.24-10

Includes fix that allows kombu to connect on localhost

closes #1245
https://pulp.plan.io/issues/1245

Revision 4c897619 View on GitHub
Added by bmbouter over 4 years ago

Upgrades kombu to 3.0.24-10

Includes fix that allows kombu to connect on localhost

closes #1245
https://pulp.plan.io/issues/1245

History

#1 Updated by bmbouter over 4 years ago

The issue is in the underlying Kombu implementation so this will involve a new patch for Pulp's downstream Kombu.

https://github.com/celery/kombu/blob/fedb42617ec0877ec5bcb85effc9d2986b6d5f36/kombu/transport/qpid.py#L1589-L1590

#2 Updated by bmbouter over 4 years ago

  • Private changed from No to Yes

#3 Updated by bmbouter over 4 years ago

  • Private changed from Yes to No

#5 Updated by mhrivnak over 4 years ago

  • Triaged changed from No to Yes

#6 Updated by dkliban@redhat.com over 4 years ago

  • Platform Release changed from 2.6.4 to 2.6.5

#7 Updated by bkearney@redhat.com over 4 years ago

  • Version set to 2.6.2 Beta

The target release for this can be 2.8

#8 Updated by bmbouter over 4 years ago

  • Status changed from ASSIGNED to POST

#9 Updated by bmbouter over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#10 Updated by dkliban@redhat.com about 4 years ago

  • Status changed from MODIFIED to ON_QA

#11 Updated by bmbouter about 4 years ago

  • Platform Release changed from 2.6.5 to 2.7.0

#12 Updated by amacdona@redhat.com about 4 years ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#14 Updated by bmbouter 9 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF