Project

Profile

Help

Issue #1173

Content Applicability Regeneration for individual consumers is sent to a single worker

Added by dkliban@redhat.com about 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 15
Quarter:

Description

The same tags are used when calculating applicability for a single consumer [0] as for all consumers bound to a specific repo [1]. As a result when multiple consumers are registered within a short amount of time, the tasks to generate content applicability profiles for these consumers are sent to a single worker and the tasks are executed serially.

[0] https://github.com/pulp/pulp/blob/2.6-dev/server/pulp/server/webservices/controllers/consumers.py#L642
[1] https://github.com/pulp/pulp/blob/86b154a74e7fac73ecd54021cf2730b522db0588/server/pulp/server/webservices/views/repositories.py#L983

History

#1 Updated by bcourt about 5 years ago

  • Triaged changed from No to Yes

Eliminate the lock for individual consumer applicability calculation as part of this.

#4 Updated by mhrivnak almost 4 years ago

We'll need to be careful to ensure that multiple calculations can run safely in parallel. Maybe since we are already batching the calculation and farming it out for parallel execution, the problem is already solved? Is there anything different about doing this for a single consumer?

#5 Updated by ipanova@redhat.com almost 4 years ago

  • Sprint/Milestone set to 31

#6 Updated by mhrivnak over 3 years ago

  • Sprint/Milestone changed from 31 to 32

#7 Updated by ttereshc over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#8 Updated by ttereshc over 3 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (ttereshc)

Unassigning since I am not working on that, solving other more high priority BZs.
Just in case someone would like to work on that.

#9 Updated by mhrivnak over 3 years ago

  • Sprint/Milestone changed from 32 to 33

#10 Updated by ttereshc over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#11 Updated by ttereshc over 3 years ago

I think applicability calculation for individual consumers is sent to the single worker only in case the task for multiple consumers is triggered.
If one will use the task for single consumer the resource will be reserved for the particular consumer only so calculation for other consumers can be done by other workers.

#12 Updated by ttereshc over 3 years ago

  • Status changed from ASSIGNED to CLOSED - WONTFIX

I suggest to use the API call for a single consumer when there is a need to calculate applicability for just one consumer (this is suitable for Katello use cases). Such tasks for different consumers will be sent to multiple workers. So this issue will be solved by using this API call.
Only when one triggers the applicabilty calculation for consumerS then such tasks will be sent to one worker only.

Please re-open this issue if you disagree and think that resource reservation for consumerS call should be removed.

#14 Updated by bmbouter over 2 years ago

  • Sprint set to Sprint 15

#15 Updated by bmbouter over 2 years ago

  • Sprint/Milestone deleted (33)

#16 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF