Project

Profile

Help

Issue #9563

closed

It should not be necessary to provide the base url to utilize a AptReleaseSigningService

Added by jxsxs about 1 year ago. Updated 11 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Using a AsciiArmoredDetachedSigningService it suffices to provide the pulp_href whilst the AptReleaseSigningService wants you to provide the full path.

i.e. http://yourpulphost.com/{pulp_href}

It's relatively hard to pin the base_path when having multiple environments. It would be really great if we only have to pass the pulp_href.

Actions #1

Updated by jxsxs about 1 year ago

Any news here quba42?

Actions #2

Updated by quba42 about 1 year ago

I had a look at how pulp_deb and pulp_rpm use signing services and noticed the following:

The AptPublicationSerializer uses the following field relation in pulp_deb/app/serializers/publication_serializers.py:

    signing_service = HyperlinkedRelatedField(
        help_text="Sign Release files with this signing key",
        many=False,
        queryset=AptReleaseSigningService.objects.all(),
        view_name="signing-services-detail",
        required=False,
    )

The corresponding RPM serializer uses just RelatedField instead of HyperlinkedRelatedField.

I suspect this is the root cause of the bug, but I have not yet had a chance to test it.

Actions #3

Updated by jxsxs about 1 year ago

That indeed sounds like a good candidate..

Actions #4

Updated by jxsxs 12 months ago

any progress here? :)

Actions #5

Updated by quba42 12 months ago

No time... Other things keep taking priority over this.

Added by Joshua Schmid 11 months ago

Revision f252699f

Use RelatedField for signing services

closes #9563

The field referencing a signing service on a publication now uses pulpcore.plugin.serializers.RelatedField, rather than: rest_framework.serializers.HyperlinkedRelatedField

The latter was causing a full URL to be stored, which in turn causes various usability issues and is inconsistent with everything else in Pulp (which use pulp_href only).

Actions #6

Updated by Anonymous 11 months ago

  • Status changed from NEW to MODIFIED

Added by Joshua Schmid 11 months ago

Revision 3e520222

Use RelatedField for signing services

closes #9563

The field referencing a signing service on a publication now uses pulpcore.plugin.serializers.RelatedField, rather than: rest_framework.serializers.HyperlinkedRelatedField

The latter was causing a full URL to be stored, which in turn causes various usability issues and is inconsistent with everything else in Pulp (which use pulp_href only).

Signed-off-by: Joshua Schmid

Actions #7

Updated by quba42 11 months ago

  • Sprint/Milestone set to 2.17.0
Actions #8

Updated by pulpbot 11 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF