Project

Profile

Help

Issue #9390

closed

Proxy authentication is not working in collection sync

Added by newswangerd about 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

We're seeing issues with customers getting aiohttp.client_exceptions.ClientHttpProxyError: 407, message='Proxy Authentication Required' error on Automation Hub 4.2 using pulpcore 3.7.5 and pulp_ansible 0.5.8 during collection sync.

This appears to be happening with Squid.

Squid logs:

1627559170.932      0 xxx.xxx.xxx.xxx TCP_DENIED/407 4125 CONNECT galaxy.ansible.com:443 - HIER_NONE/- text/html

Related issues

Related to Ansible Plugin - Issue #9075: Downloads do not seem to use proxy authentication even when specified CLOSED - CURRENTRELEASEfao89Actions
Actions #1

Updated by fao89 about 1 year ago

  • Parent task set to #9064
Actions #2

Updated by pulpbot about 1 year ago

  • Status changed from NEW to POST
Actions #3

Updated by daviddavis about 1 year ago

  • Parent task deleted (#9064)
Actions #4

Updated by daviddavis about 1 year ago

  • Related to Issue #9075: Downloads do not seem to use proxy authentication even when specified added

Added by Fabricio Aguiar about 1 year ago

Revision ec871a44

Use proxy auth from the Remote config

https://pulp.plan.io/issues/9390 closes #9390

(cherry picked from commit f97df48317caefa55912a2ad0a61be1e922f43a0)

Actions #5

Updated by Anonymous about 1 year ago

  • Status changed from POST to MODIFIED
Actions #6

Updated by fao89 about 1 year ago

  • Sprint/Milestone set to 0.5.10
Actions #7

Updated by pulpbot about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF