Project

Profile

Help

Issue #9277

closed

Katello::Errors::Pulp3Error: value too long for type character varying(255)

Added by lfu over 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Actions #1

Updated by fao89 over 1 year ago

  • Project changed from Pulp to Debian Support
Actions #2

Updated by quba42 over 1 year ago

I went and had a look at all fields in pulp_deb that have max_length=255 and I don't think any of them are likely to have caused this sync failure. (Given what I know about the repo being synced).

Without the ability to test the upstream repo, I do not know how to proceed...

Actions #3

Updated by quba42 over 1 year ago

Ok, I was given the relevant release file, and the problem is that the repo has uncharacteristically many components, thus exceeding the max length of the field in pulp_deb. The following is from the upstream release file:

Components: main mysql postgresql ldap cloud-s3 cloud-glacier cloud-azure cloud-google cloud-oracle shstore delta ndmp vsphere demo demo-support bweb netapp-hfc html-manuals kvm snapshot dedup aligned single-item-restore sybase kubernetes docker rhv db2 xenserver hdfs m365
Actions #4

Updated by quba42 over 1 year ago

Several possibilities for improving components fields:

  • Increase the max_length?
  • Chane to TextField(null=True)?
  • Change to ArrayField(CharField(max_length=255), null=True)?

Also update architectures and distributions fields?

Actions #5

Updated by quba42 about 1 year ago

I decided against the array option, since I want to do as little as possible processing of upstream metadata, before storing it in the DB. In other words, I want to keep upstream fields containing space separated string lists as a single string (containing space separated list values) in the DB.

Added by quba42 about 1 year ago

Revision 00fe4226

Allow more than 256 characters for certain DB fields

closes #9277 https://pulp.plan.io/issues/9277

The relevant fields containing a whitespace seperated list of values, in particular any fields named "distributions", "components", or "architectures".

Actions #6

Updated by pulpbot about 1 year ago

  • Status changed from NEW to POST
Actions #7

Updated by quba42 about 1 year ago

  • Status changed from POST to MODIFIED
Actions #8

Updated by quba42 about 1 year ago

  • Sprint/Milestone set to 2.16.0
Actions #9

Updated by pulpbot about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF