Project

Profile

Help

Backport #9264

closed

Backport #9243 "30-50% re-sync performance regression due to touch() of content and artifacts during sync" to 3.14.z

Added by dalley about 1 year ago. Updated 10 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
(Total: 0:00 h)
Triaged:
No
Sprint Candidate:
No
Tags:
Performance
Sprint:
Quarter:

Description

As this was a significant performance regression introduced by 3.14, we should consider backporting the fixes. This will include [0] as well which will require a small portion of the refactor introduced here [1]

[0] https://pulp.plan.io/issues/9234

[1] https://github.com/pulp/pulpcore/pull/1528/files#diff-81f6a78175bb93934b6beff952646d3ca1ef3731f1ff14492d4ec77bfc3fdf82R195


Subtasks 1 (0 open1 closed)

Backport #9268: Backport #9234 "As a user, I want to `touch` content and artifacts in bulk" to 3.14.zCLOSED - CURRENTRELEASE

Actions

Related issues

Copied from Pulp - Issue #9243: 30-50% re-sync performance regression due to touch() of content and artifacts during syncCLOSED - CURRENTRELEASEdkliban@redhat.comActions
Actions #1

Updated by dalley about 1 year ago

  • Copied from Issue #9243: 30-50% re-sync performance regression due to touch() of content and artifacts during sync added
Actions #2

Updated by dalley about 1 year ago

  • Description updated (diff)
Actions #3

Updated by dalley about 1 year ago

  • Related to Story #9234: As a user, I want to `touch` content and artifacts in bulk added
Actions #4

Updated by dalley about 1 year ago

  • Related to deleted (Story #9234: As a user, I want to `touch` content and artifacts in bulk)
Actions #5

Updated by dalley about 1 year ago

  • Related to Story #9234: As a user, I want to `touch` content and artifacts in bulk added
Actions #6

Updated by dalley about 1 year ago

  • Related to deleted (Story #9234: As a user, I want to `touch` content and artifacts in bulk)
Actions #7

Updated by pulpbot about 1 year ago

  • Status changed from NEW to POST

Added by dalley about 1 year ago

Revision f5f6713a

Use bulk touch() when processing Artifacts and Content

This patch only addresses the inefficiencies of the Stages API. Another patch is needed to address the inefficiency of the repository version modify operation.

backports: #9243

fixes #9264

(cherry picked from commit 7a41c18b9c2c30ae31c8d248162f42cb6c63c529)

Actions #8

Updated by dalley about 1 year ago

  • Status changed from POST to MODIFIED
Actions #9

Updated by pulpbot about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF