Project

Profile

Help

Issue #913

CLI shows a puppet upload is successful even though server side has an exception

Added by bmbouter over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The CLI incorrectly reports that an upload is successful even though the server may have had an exception that causes the upload to not be imported into the repo correctly.

This definitly affects the puppet module, but may affect all plugins. To reproduce:

0) create a puppet repo
1) find a valid puppet module
2) edit the tar.gz file and remove all metadata.json files (this invalidates the puppet module)
3) upload it to pulp
4) observe that it will show no errors
5) observe that there will be a server side traceback saying the metadata.json could not be found or is invalid

I expected that since the import of the uploaded module into the repo did not work that the CLI would reflect that.

The issue is that the CLI does not poll based on the async task ID given returned from the call to /pulp/api/v2/repositories/<repoid>/actions/import_upload/ It should poll and only show the user that the upload was successful if that task is successful.


Related issues

Related to Pulp - Issue #1747: Import upload task has unexpected/missing information on errorCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by cduryee over 6 years ago

  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

note from triage team: there may be a more generalized way to fix this vs just fixing for this particular content type

#2 Updated by ipanova@redhat.com over 6 years ago

seems like this kind of bug already was reported and was closed with this comment https://bugzilla.redhat.com/show_bug.cgi?id=1104157#c1

Is it still the case?

#3 Updated by bmbouter over 6 years ago

I feel this is a valid bug because the last step of uploading is an import into a repo and if the import fails then the upload also needs to fail. The succeeded message indicates to the user that the uploaded content is in the repo when in fact, it is not.

#4 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#5 Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from ASSIGNED to NEW

#6 Updated by ipanova@redhat.com almost 6 years ago

  • Assignee deleted (ipanova@redhat.com)

#7 Updated by ipanova@redhat.com over 5 years ago

  • Related to Issue #1747: Import upload task has unexpected/missing information on error added

#8 Updated by ttereshc over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#9 Updated by ttereshc over 5 years ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

Fixed here #1747#note-8

#10 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF