Project

Profile

Help

Issue #908

closed

pulp_celerybeat won't start on EL6

Added by dkliban@redhat.com over 7 years ago. Updated over 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Seems like we have a typo in the init script for pulp_celerybeat [0]. As a result you get the following traceback when you try to start pulp_celerybeat on EL6.

[cloud-user@pulp-rhel-6 ~]$ sudo service pulp_celerybeat start
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Starting pulp_celerybeat...
Traceback (most recent call last):
  File "/usr/bin/celery", line 9, in <module>
    load_entry_point('celery==3.1.11', 'console_scripts', 'celery')()
  File "/usr/lib/python2.6/site-packages/celery/__main__.py", line 30, in main
    main()
  File "/usr/lib/python2.6/site-packages/celery/bin/celery.py", line 81, in main
    cmd.execute_from_commandline(argv)
  File "/usr/lib/python2.6/site-packages/celery/bin/celery.py", line 769, in execute_from_commandline
    super(CeleryCommand, self).execute_from_commandline(argv)))
  File "/usr/lib/python2.6/site-packages/celery/bin/base.py", line 304, in execute_from_commandline
    argv = self.setup_app_from_commandline(argv)
  File "/usr/lib/python2.6/site-packages/celery/bin/base.py", line 464, in setup_app_from_commandline
    self.app = self.find_app(app)
  File "/usr/lib/python2.6/site-packages/celery/bin/base.py", line 484, in find_app
    return find_app(app, symbol_by_name=self.symbol_by_name)
  File "/usr/lib/python2.6/site-packages/celery/app/utils.py", line 222, in find_app
    sym = symbol_by_name(app, imp=imp)
  File "/usr/lib/python2.6/site-packages/celery/bin/base.py", line 487, in symbol_by_name
    return symbol_by_name(name, imp=imp)
  File "/usr/lib/python2.6/site-packages/kombu/utils/__init__.py", line 92, in symbol_by_name
    module = imp(module_name, package=package, **kwargs)
  File "/usr/lib/python2.6/site-packages/celery/utils/imports.py", line 101, in import_from_cwd
    return imp(module, package=package)
  File "/usr/lib64/python2.6/contextlib.py", line 34, in __exit__
    self.gen.throw(type, value, traceback)
  File "/usr/lib/python2.6/site-packages/celery/utils/imports.py", line 64, in cwd_in_path
    yield cwd
  File "/usr/lib/python2.6/site-packages/celery/utils/imports.py", line 101, in import_from_cwd
    return imp(module, package=package)
  File "/usr/lib/python2.6/site-packages/importlib/__init__.py", line 37, in import_module
    __import__(name)
ImportError: No module named CELERYBEAT_APP

[0] https://github.com/pulp/pulp/blob/2.7-dev/server/etc/rc.d/init.d/pulp_celerybeat#L222


Related issues

Is duplicate of Pulp - Issue #901: unable to start pulp_celerybeat on 2.7.0 alpha2 on RHEL6CLOSED - DUPLICATEActions

Added by dkliban@redhat.com over 7 years ago

Revision d429805c

Fixes typo in init script for pulp_celerybeat

Fixes #908

Added by dkliban@redhat.com over 7 years ago

Revision d429805c

Fixes typo in init script for pulp_celerybeat

Fixes #908

Actions #1

Updated by dkliban@redhat.com over 7 years ago

  • Version set to Master
Actions #2

Updated by dkliban@redhat.com over 7 years ago

  • Status changed from NEW to MODIFIED
  • % Done changed from 0 to 100
Actions #3

Updated by dkliban@redhat.com over 7 years ago

  • Is duplicate of Issue #901: unable to start pulp_celerybeat on 2.7.0 alpha2 on RHEL6 added
Actions #4

Updated by dkliban@redhat.com over 7 years ago

  • Status changed from MODIFIED to CLOSED - DUPLICATE
Actions #5

Updated by dkliban@redhat.com over 7 years ago

  • Status changed from CLOSED - DUPLICATE to MODIFIED
Actions #6

Updated by dkliban@redhat.com over 7 years ago

  • Status changed from MODIFIED to 5
Actions #7

Updated by pthomas@redhat.com about 7 years ago

  • Status changed from 5 to 6

verified

[root@qe-blade-10 ~]# service pulp_celerybeat start
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Starting pulp_celerybeat...
[root@qe-blade-10 ~]# service pulp_celerybeat status
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
pulp_celerybeat (pid 6648) is running.
[root@qe-blade-10 ~]# 
Actions #8

Updated by pthomas@redhat.com about 7 years ago

Verified

[root@qe-blade-10 ~]# service pulp_celerybeat start
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Starting pulp_celerybeat...
[root@qe-blade-10 ~]# service pulp_celerybeat status
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
pulp_celerybeat (pid 6648) is running.
[root@qe-blade-10 ~]# 
Actions #9

Updated by amacdona@redhat.com almost 7 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE
Actions #11

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF