Project

Profile

Help

Story #8873

pulp 3 stops when encounters 403 error

Added by mwaqas@bloombergindustry.com 3 months ago. Updated 3 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

pulp 2, when encounters 403 errors it just moves on whereas pulp 3 stops and doesn't continue.

pulp2.png (590 KB) pulp2.png mwaqas@bloombergindustry.com, 06/07/2021 05:34 PM
pulp3.png (145 KB) pulp3.png mwaqas@bloombergindustry.com, 06/07/2021 05:34 PM
250
250

Related issues

Related to RPM Support - Issue #8787: "UnboundLocalError: local variable 'result' referenced before assignment" on attempt to sync some reposCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Story #5286: As a user, a Remote should provide an option that allows download errors, e.g. 404 errors to still allow creation of a RepositoryVersionNEW

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dkliban@redhat.com 3 months ago

  • Tracker changed from Issue to Story
  • % Done set to 0
  • Severity deleted (2. Medium)
  • Triaged deleted (No)

We should consider adding options for what errors are acceptable. I am converting this to a Story since this would be a new feature.

#2 Updated by jsherril@redhat.com 3 months ago

  • Tags Katello added

Katello is interested in this feature, but at a 'normal' priority

#3 Updated by ipanova@redhat.com 3 months ago

  • Is duplicate of Story #8881: As a user, Pulp will retry downloads by default 3 times and I can configure this value on my Remote added

#4 Updated by ipanova@redhat.com 3 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by ipanova@redhat.com 3 months ago

  • Is duplicate of deleted (Story #8881: As a user, Pulp will retry downloads by default 3 times and I can configure this value on my Remote)

#6 Updated by ipanova@redhat.com 3 months ago

  • Status changed from CLOSED - DUPLICATE to NEW

#7 Updated by dalley 3 months ago

@mwaqas@bloombergindustry.com are there particular repositories where you frequently encounter this issue?

#8 Updated by dalley 3 months ago

  • Related to Issue #8787: "UnboundLocalError: local variable 'result' referenced before assignment" on attempt to sync some repos added

#9 Updated by mwaqas@bloombergindustry.com 3 months ago

@mwaqas@bloombergindustry.com are there particular repositories where you frequently encounter this issue?

you can refer to ticket my colleague opened https://pulp.plan.io/issues/8875

Thanks!

#10 Updated by dalley 3 months ago

So this ties into the retry discussion slightly. If one RPM fails to download (for any reason, be it 403, or repeated server errors, etc.) what should we do? Should the sync fail or should we fall back to making that one content unit "on_demand" and hope that the issue later resolves itself, or the RPM is never downloaded?

I think yes.

#11 Updated by dalley 3 months ago

  • Status changed from NEW to POST
  • Assignee set to dalley

#13 Updated by dalley 3 months ago

  • Status changed from POST to CLOSED - DUPLICATE
  • Assignee deleted (dalley)

Closing in favor of https://pulp.plan.io/issues/5286 which has more detail and discussion

#14 Updated by dalley 3 months ago

  • Is duplicate of Story #5286: As a user, a Remote should provide an option that allows download errors, e.g. 404 errors to still allow creation of a RepositoryVersion added

Please register to edit this issue

Also available in: Atom PDF