Project

Profile

Help

Issue #8722

closed

The checksum type from a remote source is not used by for a publication

Added by ttereshc over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 98
Quarter:

Description

To reproduce:

Observe that metadata uses sha256 checksum type.

This affects Pulp 3 -> Pulp 2 sync (aka smart proxy use case), because Pulp 2 is looking at the metadata checksum (sha256 in our case) and uses it for everything, including content. But in case of on_demand sync only md5 is available in the reproducer example.

Actions #1

Updated by ttereshc over 1 year ago

I think the root cause of the issue is the evolution of the checksum type feature.
First, only sha256 was used and it was treated as a default for publications.
Then Pulp started accepting a one-time option at publication time to have a custom checksum type.
Then Pulp started to consider the original checksum type which comes from the remote source, and the precedence was: one-time option at publish time, original checksum type, default value.
Then the configuration of checksum type became available on the repository model, and it has a default value, which is currently has higher precedence than the original checksum type. I think it is not an intentional behaviour.

I suggest to remove a default for the repository configuration and allow it to be not configured.

Actions #2

Updated by ipanova@redhat.com over 1 year ago

ttereshc wrote:

I think the root cause of the issue is the evolution of the checksum type feature.
First, only sha256 was used and it was treated as a default for publications.
Then Pulp started accepting a one-time option at publication time to have a custom checksum type.
Then Pulp started to consider the original checksum type which comes from the remote source, and the precedence was: one-time option at publish time, original checksum type, default value.
Then the configuration of checksum type became available on the repository model, and it has a default value, which is currently has higher precedence than the original checksum type. I think it is not an intentional behaviour.

I suggest to remove a default for the repository configuration and allow it to be not configured.

Docs also should be updated https://docs.pulpproject.org/pulp_rpm/workflows/create_sync_publish.html#create-a-publication

Actions #5

Updated by dalley over 1 year ago

Then the configuration of checksum type became available on the repository model, and it has a default value, which is currently has higher precedence than the original checksum type. I think it is not an intentional behaviour.

Agreed.

Actions #6

Updated by pulpbot over 1 year ago

  • Status changed from NEW to POST
Actions #7

Updated by ttereshc over 1 year ago

  • Assignee set to dalley
  • Sprint set to Sprint 98
Actions #8

Updated by dalley over 1 year ago

  • Triaged changed from No to Yes

Added by dalley over 1 year ago

Revision 37bdbfb7

Allow checksum types to be unspecified for publish

Intelligently decide which checksum types to use if the user left them unspecified.

closes: #8722 https://pulp.plan.io/issues/8722

Actions #9

Updated by dalley over 1 year ago

  • Status changed from POST to MODIFIED
Actions #10

Updated by pulpbot over 1 year ago

  • Sprint/Milestone set to 3.13.0
Actions #11

Updated by pulpbot over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF