Project

Profile

Help

Story #8673

closed

Auto-publishing should be more fault-tolerant

Added by sskracic@redhat.com over 1 year ago. Updated 10 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 111
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_rpm/2273":https://github.com/pulp/pulp_rpm/issues/2273


I admit the title is a bit vague.

During auto-publishing sync of a very large repository (rhel-7-server-rpms), the rq process got killed by oom-killer sometime in the middle of the publishing step. So the new repository version (1) got created, but accompanying publication did not.

On the subsequent sync runs, the repository did not get published, as no new content was available to sync, hence a new repository version was not created, which in turn should trigger publication and distribution update.

Of course, the repo can still be published and distributed using the non-autopublishing REST API, but I wonder whether the behavior was intended.


Related issues

Related to Pulp - Task #8740: [EPIC] Publication based plugins should use either `distribution.repository` or `distribution.publication` but not bothCLOSED - DUPLICATE

Actions
Related to RPM Support - Story #6353: As a user, I can mirror RPM repository content and metadataCLOSED - CURRENTRELEASEdalley

Actions
Actions #1

Updated by dalley over 1 year ago

  • Related to Task #8740: [EPIC] Publication based plugins should use either `distribution.repository` or `distribution.publication` but not both added
Actions #2

Updated by dalley over 1 year ago

  • Related to Story #6353: As a user, I can mirror RPM repository content and metadata added
Actions #3

Updated by dalley over 1 year ago

#6353 should help with this, since metadata mirroring avoids the need for a publishing step - even via auto-publishing.

Although of course for custom repos, auto-publish is necessary to make repo modifications convenient.

Actions #4

Updated by dalley over 1 year ago

@sskracic I would call this "an expected but unfortunate corner case". In this situation, which would you prefer to happen?

  • The current behavior (with maybe some additional logging of warnings)
  • Have entire task fail and all changes reverted, including the destruction of the repository version that was created. This means that the operation that created the repository version would need to be re-done in its entirety.
Actions #5

Updated by sskracic@redhat.com over 1 year ago

dalley wrote:

@sskracic I would call this "an expected but unfortunate corner case". In this situation, which would you prefer to happen?

  • The current behavior (with maybe some additional logging of warnings)
  • Have entire task fail and all changes reverted, including the destruction of the repository version that was created. This means that the operation that created the repository version would need to be re-done in its entirety.

If feasible, I would prefer the latter. My understanding is that with the artifacts already being downloaded, only their associations to the new repo version will need to be redone on the next sync run.

Actions #6

Updated by dalley about 1 year ago

  • Sprint set to Sprint 101
Actions #7

Updated by ipanova@redhat.com about 1 year ago

  • Sprint changed from Sprint 101 to Sprint 102
Actions #8

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 102 to Sprint 103
Actions #9

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 103 to Sprint 104
Actions #10

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 104 to Sprint 105
Actions #11

Updated by dalley about 1 year ago

  • Priority changed from Normal to Low
Actions #12

Updated by rchan about 1 year ago

  • Sprint changed from Sprint 105 to Sprint 106
Actions #13

Updated by rchan 12 months ago

  • Sprint changed from Sprint 106 to Sprint 107
Actions #14

Updated by rchan 12 months ago

  • Sprint changed from Sprint 107 to Sprint 108
Actions #15

Updated by rchan 11 months ago

  • Sprint changed from Sprint 108 to Sprint 109
Actions #16

Updated by rchan 11 months ago

  • Sprint changed from Sprint 109 to Sprint 110
Actions #17

Updated by rchan 10 months ago

  • Sprint changed from Sprint 110 to Sprint 111
Actions #18

Updated by pulpbot 10 months ago

  • Description updated (diff)
  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF