Project

Profile

Help

Issue #8487

closed

Repository list endpoint shows repos that are meant to be hidden

Added by daviddavis over 3 years ago. Updated about 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 98
Quarter:

Description

The pulp_rpm plugin has "sub_repos" for distribution trees. These repos are not meant for users to view/manage. It filters out these repos in its viewset.

The problem is that the generic repo endpoint (/api/v3/repositories/) does not honor that.

Proposal

Add a new field (hidden?) to Repository. This would be useful for plugins that need to hide repos. But also for features like #7832.

Also, have the generic repo list use this field and update pulp_rpm to use this field.


Related issues

Blocks RPM Support - Issue #8494: Sub repos are showing up at /pulp/api/v3/repositories/CLOSED - CURRENTRELEASEdalleyActions

Also available in: Atom PDF