Project

Profile

Help

Issue #8190

AttributeError: 'NoneType' object has no attribute 'query_params'

Added by ipanova@redhat.com 2 months ago. Updated 14 days ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 93
Quarter:

Description

$ http GET  :24817/pulp/api/v3/users/3/ --auth admin:password
HTTP/1.1 200 OK
Access-Control-Expose-Headers: Correlation-ID
Allow: GET, HEAD, OPTIONS
Connection: close
Content-Length: 779
Content-Type: application/json
Correlation-ID: 05805463d9be4db1a3e39b48c3ee0d56
Date: Tue, 02 Feb 2021 12:03:04 GMT
Server: gunicorn/20.0.4
Vary: Accept, Cookie
X-Frame-Options: SAMEORIGIN

{
    "date_joined": "2021-02-02T12:01:25.231244Z",
    "email": "",
    "first_name": "",
    "groups": [
        {
            "name": "container.namespace.owners.test",
            "pulp_href": "/pulp/api/v3/groups/1/"
        },
        {
            "name": "container.distribution.owners.39d08bc1-37fb-4bde-85de-6da9a5c95b03",
            "pulp_href": "/pulp/api/v3/groups/4/"
        },
        {
            "name": "container.namespace.owners.ina",
            "pulp_href": "/pulp/api/v3/groups/7/"
        },
        {
            "name": "container.distribution.owners.880dc562-f95a-4672-8be6-a0593545a143",
            "pulp_href": "/pulp/api/v3/groups/10/"
        },
        {
            "name": "container.namespace.owners.ina1",
            "pulp_href": "/pulp/api/v3/groups/13/"
        },
        {
            "name": "container.distribution.owners.5cbaed7b-f145-4514-a1f2-b54b7851041a",
            "pulp_href": "/pulp/api/v3/groups/16/"
        }
    ],
    "id": 3,
    "is_active": true,
    "is_staff": false,
    "last_name": "",
    "pulp_href": "/pulp/api/v3/users/3/",
    "username": "ina"
}

(pulp) [vagrant@pulp3-source-fedora32 ~]$ http GET  :24817/pulp/api/v3/users/3/permissions/ --auth admin:password
HTTP/1.1 500 Internal Server Error
Access-Control-Expose-Headers: Correlation-ID
Connection: close
Content-Length: 27
Content-Type: text/html
Correlation-ID: f1d9b4f7d1ee42498eb915e45ed12609
Date: Tue, 02 Feb 2021 12:03:14 GMT
Server: gunicorn/20.0.4
Vary: Cookie
X-Frame-Options: SAMEORIGIN

<h1>Server Error (500)</h1>

(pulp) [vagrant@pulp3-source-fedora32 ~]$ pjournal 
-- Logs begin at Thu 2020-11-19 21:47:04 UTC. --
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:   File "/usr/local/lib/pulp/lib64/python3.8/site-packages/rest_framework/relations.py", line 540, in to_representation
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:     return [
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:   File "/usr/local/lib/pulp/lib64/python3.8/site-packages/rest_framework/relations.py", line 541, in <listcomp>
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:     self.child_relation.to_representation(value)
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:   File "/home/vagrant/devel/pulpcore/pulpcore/app/serializers/task.py", line 32, in to_representation
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:     request = self._get_request_without_query_params()
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:   File "/home/vagrant/devel/pulpcore/pulpcore/app/serializers/task.py", line 41, in _get_request_without_query_params
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]:     request.query_params._mutable = True
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]: AttributeError: 'NoneType' object has no attribute 'query_params'
Feb 02 12:03:14 pulp3-source-fedora32.fluffy.example.com gunicorn[553916]: 127.0.0.1 - admin [02/Feb/2021:12:03:14 +0000] "GET /pulp/api/v3/users/3/permissions/ HTTP/1.1" 500 27 "-" "HTTPie/2.2.0"



Related issues

Related to Pulp - Issue #8396: AttributeError: 'NoneType' object has no attribute 'get_host'POST<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by fao89 2 months ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 89

#2 Updated by rchan 2 months ago

  • Sprint changed from Sprint 89 to Sprint 90

#3 Updated by daviddavis about 2 months ago

  • Sprint deleted (Sprint 90)

#4 Updated by lmjachky 18 days ago

  • Related to Issue #8396: AttributeError: 'NoneType' object has no attribute 'get_host' added

#5 Updated by lmjachky 18 days ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to lmjachky
  • Sprint set to Sprint 93

#6 Updated by lmjachky 14 days ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

I am closing this issue as a duplicate of https://pulp.plan.io/issues/8396.

Please register to edit this issue

Also available in: Atom PDF