Project

Profile

Help

Issue #8043

closed

ValueError: Path is duplicated when syncing http://mirror.centos.org/centos/7/opstools/x86_64/

Added by iballou over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

A Katello user brought up this issue here: https://community.theforeman.org/t/cannot-create-repository-version-path-is-duplicated/21714

I also was able to reproduce it.

The user believes it has to do with the repo containing "rubygem-rspec-expectations-doc-3.5.0-1.el7.1.noarch.rpm. in two paths. (/x86_64/logging/ & /x86_64/sensu)"

This older issue may be related https://pulp.plan.io/issues/6303

Pulp versions:

pulp-2to3-migration (0.5.1)
pulp-ansible (0.5.1)
pulp-certguard (1.0.3)
pulp-container (2.1.0)
pulp-file (1.3.0)
pulp-rpm (3.7.0)
pulpcore (3.7.3)

Related issues

Is duplicate of RPM Support - Issue #7208: Error during sync : Path is duplicatedCLOSED - CURRENTRELEASEggaineyActions
Actions #1

Updated by ggainey over 1 year ago

  • Is duplicate of Issue #7208: Error during sync : Path is duplicated added
Actions #2

Updated by ggainey over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF