Project

Profile

Help

Story #7671

Story #7670: [EPIC] As a Galaxy V3 api user, I can sync repository metadata

As a Galaxy V3 api user, I have a /metadata/ endpoint

Added by fao89 about 1 year ago. Updated 8 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

/metadata/ - 200 OK response with:

{
        "deprecated_collections": [
        {
                        "namespace": "cisco",
                        "name": "management",
                },
                {
                        "namespace": "another_ns",
                        "name": "another_collection_name",
                },
                {
                        "namespace": "foo",
                        "name": "bar",
                }
        ]
}

This gets added to the Galxy V3 API here: https://github.com/pulp/pulp_ansible/blob/master/pulp_ansible/app/urls.py#L40-L74

/metadata/?deprecated_collections="cisco" - 200 OK repsonse with:

{
        "deprecated_collections": ["cisco", "another_collection_name", "foo"]
}

Related issues

Is duplicate of Ansible Plugin - Story #7940: As a user, I have a new v3/metadata/collections/ endpoint returning all collections unpaginatedCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter 8 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#2 Updated by bmbouter 8 months ago

  • Is duplicate of Story #7940: As a user, I have a new v3/metadata/collections/ endpoint returning all collections unpaginated added

Please register to edit this issue

Also available in: Atom PDF