Project

Profile

Help

Issue #7543

"reserved_resources_record" missing from tasks (python client)

Added by wibbit 28 days ago. Updated 27 days ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
API Bindings
Sprint:
Quarter:

Description

When performing a .read(task_href='') using the python client, no "reserved_resources_record" is present, making it impossible to track down which publisher a task was associated with via the python client.

>>> tasks.read(task_href='/pulp/api/v3/tasks/1d713b51-22db-4582-bd13-88da822cd91f/')
{'child_tasks': [],
 'created_resources': [None],
 'error': None,
 'finished_at': datetime.datetime(2020, 9, 18, 8, 57, 11, 669495, tzinfo=tzutc()),
 'name': 'pulp_rpm.app.tasks.publishing.publish',
 'parent_task': None,
 'progress_reports': [],
 'pulp_created': datetime.datetime(2020, 9, 18, 8, 57, 11, 387721, tzinfo=tzutc()),
 'pulp_href': '/pulp/api/v3/tasks/1d713b51-22db-4582-bd13-88da822cd91f/',
 'started_at': datetime.datetime(2020, 9, 18, 8, 57, 11, 474496, tzinfo=tzutc()),
 'state': 'completed',
 'task_group': None,
 'worker': '/pulp/api/v3/workers/2ab4deb9-897e-43d4-9cdf-a6f95cf8f4e5/'}

Version: 3.6.0


Related issues

Is duplicate of Pulp - Issue #7347: OpenAPI specs: reserved_resources_record missing from TaskResponse CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by daviddavis 27 days ago

  • Description updated (diff)

#2 Updated by fao89 27 days ago

  • Related to Issue #7347: OpenAPI specs: reserved_resources_record missing from TaskResponse added

#3 Updated by dkliban@redhat.com 27 days ago

  • Is duplicate of Issue #7347: OpenAPI specs: reserved_resources_record missing from TaskResponse added

#4 Updated by dkliban@redhat.com 27 days ago

  • Related to deleted (Issue #7347: OpenAPI specs: reserved_resources_record missing from TaskResponse )

#5 Updated by dkliban@redhat.com 27 days ago

  • Status changed from NEW to CLOSED - DUPLICATE

#6 Updated by ipanova@redhat.com 27 days ago

this issue has been addressed in 3.6.1

Please register to edit this issue

Also available in: Atom PDF