Project

Profile

Help

Issue #7254

closed

pulp_installer fails idempotency tests with pip 20.2

Added by mdepaulo@redhat.com almost 4 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 78
Quarter:

Description

pulp_installer is not idempotent (always reports changed, and therefore fails molecule CI) on these tasks:

pulp_common : Install pulpcore via PyPI
pulp_common : Install Pulp plugins via PyPI

Upon further investigation, this is caused by:

  1. A bug in pip 20.2 (we upgrade to the latest pip) comparing package names with '.' vs '_'
  2. The packages ruamel.yaml ruamel.yaml.clib triggering this bug
  3. Those 2 packages always getting reinstalled, at the same version, whenever pip installs something that depends on them (drf-yasg, and therefore pupcore and its plugins.) This therefore makes the ansible tasked CHANGED rathe than OK.

Easiest solution is to just have our ansible pip task:

pulp_common: Upgrade to a recent edition of pip (supporting manylinux2014)

Exclude 20.2 specifically. 20.2.1 will almost definitely have a fix for this: The bug report is very active, and there's an open PR to fix it.

Also available in: Atom PDF