Project

Profile

Help

Issue #7103

closed

pulp-rpm won't support django-filter 2.3.0

Added by ggainey over 3 years ago. Updated over 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 76
Quarter:

Description

Looks like some new checks were introduced:

TypeError: 'Meta.fields' must not contain non-model field names: content

Dependabot PR: https://github.com/pulp/pulpcore/pull/744


Related issues

Copied from Pulp - Issue #6915: Pulpcore doesn't support django-filter 2.3.0CLOSED - CURRENTRELEASEggaineyActions
Actions #1

Updated by ggainey over 3 years ago

  • Copied from Issue #6915: Pulpcore doesn't support django-filter 2.3.0 added
Actions #2

Updated by pulpbot over 3 years ago

  • Status changed from ASSIGNED to POST

Added by ggainey over 3 years ago

Revision b6c6bac9 | View on GitHub

Remove non-model-fields from Meta.fields of filters

closes #7103 [nocoverage]

Actions #3

Updated by ggainey over 3 years ago

  • Status changed from POST to MODIFIED
Actions #4

Updated by ttereshc over 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
Actions #5

Updated by ttereshc over 3 years ago

  • Sprint/Milestone set to Pulp RPM 3.5.0

Also available in: Atom PDF