Project

Profile

Help

Issue #7055

Docs indicate that pulp_installer Ansible roles are not currently available on Ansible Galaxy

Added by mcorr over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation
Sprint:
Quarter:

Description

Hi there,

I am just reading through the docs for the pulp_installer.

On the first page of the docs: https://pulp-installer.readthedocs.io/en/latest/#pulp-3-ansible-installer there is the line:

The roles are not currently available on Ansible Galaxy; to run the Pulp 3 Ansible installer, the pulp_installer git repository must be cloned or downloaded.

Then in another chapter:

Pulp 3 Ansible installer is a collection of roles to install or upgrade Pulp 3 hosted on galaxy: https://galaxy.ansible.com/pulp/pulp_installer

Then in the changelog from the beginning of June:

Document how to install from galaxy #6836

So, either I am confused or the docs need a bit of updating.

It also seems to me that there is duplication within the "Home" and "Getting Started" sections. Requirements/System requirements etc.

If what I understand is correct, I am happy to make the changes myself:

Associated revisions

Revision 9b8c68e3 View on GitHub
Added by mcorr over 1 year ago

Remove line saying roles unavailable on Galaxy

  • Update Ansible version (Galaxy site says 2.9 is required)
  • s/install/installation
  • Some readability improvements
  • Move requirements to one section

fixes #7055

Revision 9b8c68e3 View on GitHub
Added by mcorr over 1 year ago

Remove line saying roles unavailable on Galaxy

  • Update Ansible version (Galaxy site says 2.9 is required)
  • s/install/installation
  • Some readability improvements
  • Move requirements to one section

fixes #7055

History

#1 Updated by bmbouter over 1 year ago

the docs need updating. You're understanding is correct that the docs are out of date, and the installer is now recommended to be installed as a collection delivered from ansible galaxy.

#2 Updated by mcorr over 1 year ago

  • Assignee set to mcorr

#3 Updated by pulpbot over 1 year ago

  • Status changed from NEW to POST

#4 Updated by mcorr over 1 year ago

  • Status changed from POST to MODIFIED

#5 Updated by mcorr over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

This has been updated.

#6 Updated by fao89 over 1 year ago

  • Sprint/Milestone set to 3.5.0

Also available in: Atom PDF