Project

Profile

Help

Issue #6523

pulp_rpm 3.3.0 cannot install on the pulp-operator pulp container because Fedora's createrepo_c is too old

Added by mdepaulo@redhat.com 6 months ago. Updated 5 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 71
Quarter:

Description

It requires createrepo_c 0.15.10, but Fedora 30 (currently used), 31 and 32 still have earlier 0.15.x versions of createrepo_c.

I will workaround this by installing the build dependencies of createrepo_c in the container ,and then let it be installed/built from PyPI.

Associated revisions

Revision ebc4006e View on GitHub
Added by Mike DePaulo 6 months ago

Problem: pulp_rpm 3.3.0 cannot install on the pulp-operator pulp container because Fedora's createrepo_c is too old

Solution: Temporarily replace the createrepo_c RPM with its build-dependencies, and let createrepo_c get installed & built from PyPI.

fixes: #6523

History

#1 Updated by pulpbot 6 months ago

  • Status changed from NEW to POST

#2 Updated by rchan 6 months ago

  • Sprint changed from Sprint 70 to Sprint 71

#4 Updated by Anonymous 6 months ago

  • Status changed from POST to MODIFIED

#5 Updated by dkliban@redhat.com 5 months ago

  • Sprint/Milestone set to 3.4.0

#6 Updated by dkliban@redhat.com 5 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF