Project

Profile

Help

Issue #6470

CentOS directory KS structure is no longer RH compatible

Added by lzap@redhat.com over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 71
Quarter:

Description

Hello, CentOS8 changed the directory structure. Instead centos/7/os/x86_64/ base directory it's now stored as centos/8/BaseOS/x86_64/os/ and centos/8/AppStream/x86_64/os/ respectively. For kickstart it's the same story:

The issue is, this is a different path than Red Hat has on CDN. Anaconda from CentOS assumes this new layout and includes AppStream using relative path so it ends up as:

/pulp/repos/ORG/Library/custom/CentOS8/base-x86_64/../../../AppStream/x86_64/os/

That is unfortunately incorrect. So Pulp no longer works for CentOS8 kickstart repositories, I mean it will sync the content successfully but Anaconda will not install the OS due to missing repository. Workaround is quite dirty, an Apache rewrite rule that cannot be too much generic.

I think it's important that kickstarting CentOS8 works fine and out of box with Pulp, therefore I am filing this issue. There are two bug reports already filed:

Problem is that in Foreman/Katello we can only implement a dirty workaround. And CentOS will unlikely change directory structure now in the middle of a major release. I also do believe that it's unlikely to see a change in CentOS Anaconda to solve this situation and therefore Pulp need to detect CentOS and set up some links or change directory structure so it works out of box.

Thanks for help with this.

History

#1 Updated by ttereshc over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 70

#2 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 70 to Sprint 71

#3 Updated by dkliban@redhat.com over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 users can sync both BaseOS and Appstream repositories separately and construct the relative paths for them in such a way that this will work. We don't intend to change any behavior related to this in Pulp 2. However, we are making sure that CentOS 8 kickstart repos work well in Pulp 3.

https://pulp.plan.io/issues/6568

Please register to edit this issue

Also available in: Atom PDF