Project

Profile

Help

Task #6273

Story #5762: [Epic] CI Improvements

pulp_rpm_prerequisites CI shold test upgrading from older versions of pulp_rpm

Added by mdepaulo@redhat.com over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - COMPLETE
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
CI/CD
Sprint:
Quarter:

Description

Currently the default-upgrade and source-upgrade scenarios test the following upgrade: pulpcore 3.0.0, pulp_file 3.0.0 -> pulpcore latest, pulp_file latest, pulp_rpm latest

The starting state (from the container images on quay.io) should include pulp_rpm


Related issues

Related to RPM Support - Issue #6267: Problem: pulp_rpm's need for system-wide packages conflicts with having a newer version of pipCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision e46795a3 View on GitHub
Added by Mike DePaulo over 1 year ago

pulp_rpm_prerequisites CI shold test upgrading from older versions of pulp_rpm

Solution: upgrade from newly generated pulpcore 3.1.1 / pulp_file 0.1.1 / pulp_rpm 3.1.0 / pulp_rpm_prerequisites 3.1.0 / createrepo_c 0.15.5 images.

fixes: #6273

re: #6267 Problem: pulp_rpm's need for system-wide packages conflicts with having a newer version of pip

History

#1 Updated by mdepaulo@redhat.com over 1 year ago

  • Related to Issue #6267: Problem: pulp_rpm's need for system-wide packages conflicts with having a newer version of pip added

#2 Updated by Anonymous over 1 year ago

  • Status changed from NEW to MODIFIED
  • % Done changed from 0 to 100

#3 Updated by mdepaulo@redhat.com over 1 year ago

  • Status changed from MODIFIED to CLOSED - COMPLETE

#4 Updated by bmbouter over 1 year ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF