Project

Profile

Help

Issue #5767

closed

ansible-pulp fails due to undefined pulp_settings_file when its roles are dynamically included

Added by mdepaulo@redhat.com over 2 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
CI/CD
Sprint:
Quarter:

Description

This issue was caused by the introduction of the vars pulp_settings_file and pulp_config_dir to the pulp role (with default values), but it being used in other roles as well.

[The previous solution](https://github.com/pulp/ansible-pulp/pull/183) (now closed w/o merge) to this problem was to declare static dependencies of the other roles on the pulp role, but this means that if the roles are dynamically called, the pulp role will be re-run even more times.

I now believe the better solution is to add the 2 variables to the "defaults" of all roles that use it. So that it is a loosely coupled variable/role. We do this already for some other variables (pulp_user & pulp_install_dir).

Actions #1

Updated by mdepaulo@redhat.com over 2 years ago

  • Blocks Task #5766: ansible-pulp CI should test calling roles from dynamic "include_role" in addition to static "roles" added
Actions #2

Updated by fao89 over 2 years ago

  • Triaged changed from No to Yes
Actions #3

Updated by mdepaulo@redhat.com over 2 years ago

  • Subject changed from Ansible roles fail to evaluate pulp_settings_file when dynamically included to ansible-pulp fails due to undefined pulp_settings_file when its roles are dynamically included
Actions #4

Updated by fao89 over 2 years ago

  • Tags CI/CD added
Actions #5

Updated by bmbouter about 2 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)
Actions #6

Updated by dkliban@redhat.com about 2 years ago

  • Blocks deleted (Task #5766: ansible-pulp CI should test calling roles from dynamic "include_role" in addition to static "roles")
Actions #7

Updated by dkliban@redhat.com almost 2 years ago

  • Status changed from NEW to CLOSED - CURRENTRELEASE

Also available in: Atom PDF