Project

Profile

Help

Issue #5569

Cannot poll a collection import immediately after the collection is uploaded

Added by daviddavis over 1 year ago. Updated 9 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The problem is that the task creates the CollectionImport object and so it cannot be polled until the task starts. This causes 404s for galaxy.

More info: https://github.com/ansible/galaxy-dev/issues/124

Associated revisions

Revision c040a0bb View on GitHub
Added by daviddavis over 1 year ago

Creating a CollectionImport immediately after the task

Galaxy was polling the CollectionImport which wasn't being created until the task started. This caused 404s.

fixes #5569

History

#1 Updated by daviddavis over 1 year ago

  • Status changed from NEW to POST

#3 Updated by daviddavis over 1 year ago

  • Status changed from POST to MODIFIED

#5 Updated by bmbouter 9 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF