Project

Profile

Help

Issue #5547

closed

Settings in /etc/pulp/settings.py has lower priority than settings provided by plugins

Added by ttereshc over 2 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

If plugins set their settings.py, the configuration parameters from plugins are chosen over the ones specified in /etc/pulp/settings.py.

To reproduce:
- Install the migration plugin https://github.com/pulp/pulp-2to3-migration/
- Modify it's default configuration to anything
- Set the same configuration parameter in /etc/pulp/settings.py
- Check which value is used


Related issues

Is duplicate of Pulp - Issue #5425: User additions to /etc/pulp/settings.py can be unexpectedly overwrittenCLOSED - CURRENTRELEASEdkliban@redhat.comActions
Actions #1

Updated by ttereshc over 2 years ago

  • Description updated (diff)
Actions #2

Updated by ttereshc over 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #3

Updated by ttereshc over 2 years ago

  • Is duplicate of Issue #5425: User additions to /etc/pulp/settings.py can be unexpectedly overwritten added

Also available in: Atom PDF