Project

Profile

Help

Issue #5381

closed

auto-distribution of repositories not supported

Added by jaymzh over 3 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Pulpcore has auto-distribution of repositories... if you add a repository without a version to a distribution, then as the repo is updated the distribution tracks the latest version (see https://docs.pulpproject.org/en/3.0/nightly/workflows/exposing-content.html#auto-distribution-of-a-repository)

In pulp_deb this doesn't work. There's an additional abstraction (publication), and when the publication is pointed to the the repository without a version, it looks up the latest version and hardcodes that. :(


Related issues

Related to Debian Support - Issue #7390: As a user i want to upload package to a repository and have it available immediately in distribution (skip publication step)CLOSED - DUPLICATEActions
Is duplicate of Debian Support - Issue #8684: Add support for automatic publishing and distributingCLOSED - DUPLICATEquba42Actions
Actions #1

Updated by jaymzh over 3 years ago

It turns out that the way this should work is you associate the distribution directly with the repo, but when I try to do that it says unexpected field.

Actions #2

Updated by mdellweg almost 3 years ago

pulp_deb needs publications (for creating metadata). So this feature would only work if there were facilities for auto-publishing which i am unaware of.

Can we defer this to a wishlist?

Meanwhile the cron like automation that triggers the sync could also perform the publication and distribution to mimic the auto-distribution.

Actions #3

Updated by quba42 over 2 years ago

  • Related to Issue #7390: As a user i want to upload package to a repository and have it available immediately in distribution (skip publication step) added
Actions #4

Updated by quba42 over 2 years ago

  • Sprint/Milestone set to Wishlist
Actions #5

Updated by quba42 over 1 year ago

  • Related to Issue #8684: Add support for automatic publishing and distributing added
Actions #6

Updated by quba42 over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Sprint/Milestone deleted (Wishlist)

Closed in favor of #8684.

Actions #7

Updated by quba42 over 1 year ago

  • Related to deleted (Issue #8684: Add support for automatic publishing and distributing)
Actions #8

Updated by quba42 over 1 year ago

  • Is duplicate of Issue #8684: Add support for automatic publishing and distributing added

Also available in: Atom PDF