Project

Profile

Help

Issue #7390

closed

As a user i want to upload package to a repository and have it available immediately in distribution (skip publication step)

Added by mntzn about 2 years ago. Updated 9 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_deb/393":https://github.com/pulp/pulp_deb/issues/393


Current workflow is to:

  1. upload content (package)

  2. add content to repo

  3. create publication from repo

  4. create/update distribution with latest publication

Steps 3, 4 can be omitted and package that have been uploaded to a repository should be immediately available in distribution (as alternative to current workflow)


Related issues

Related to Debian Support - Issue #5381: auto-distribution of repositories not supportedCLOSED - DUPLICATEActions
Related to Debian Support - Issue #8684: Add support for automatic publishing and distributingCLOSED - DUPLICATEquba42Actions
Actions #1

Updated by quba42 about 2 years ago

For me to evaluate this request it would be helpful if you could point me in the direction of other plugins that support this workflow. (Otherwise I will just need to look for the relevant documentation myself).

Right now I cannot imagine how it should work to skip the publication step, since that is the step that actually does all the work of creating the metadata files needed for the final repository... Perhaps there is some new pulpcore way for this to happen implicitly with a single step.

Actions #2

Updated by quba42 about 2 years ago

  • Sprint/Milestone set to Wishlist
Actions #3

Updated by quba42 about 2 years ago

  • Related to Issue #5381: auto-distribution of repositories not supported added
Actions #4

Updated by quba42 about 2 years ago

Is this just a duplicate of https://pulp.plan.io/issues/5381, or are they different?

Actions #5

Updated by quba42 over 1 year ago

  • Related to Issue #8684: Add support for automatic publishing and distributing added
Actions #6

Updated by pulpbot 9 months ago

  • Description updated (diff)
  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF