Project

Profile

Help

Story #5084

As a user, after copy or repo version creation there are no advisories with the same id

Added by ttereshc over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Similar to #4295, just for copy and any other repo version creation case when units are added.

Suggested solution

Each repo version should have no more than one UpdateRecord with the same id.

Decide which UpdateRecord to keep based on the criteria defined in #4295.

Proposal :
- awaits a decision on the thread: https://www.redhat.com/archives/pulp-dev/2019-June/msg00077.html


Related issues

Related to RPM Support - Story #4898: As a user, no "duplicated" content is present in a repo versionCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of RPM Support - Story #4295: As a user, a repository version has no advisories with the same idCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ttereshc about 2 years ago

  • Tags Pulp 3 RPM blocker added

#2 Updated by daviddavis about 2 years ago

  • Related to Story #4898: As a user, no "duplicated" content is present in a repo version added

#3 Updated by daviddavis about 2 years ago

  • Related to Story #4295: As a user, a repository version has no advisories with the same id added

#4 Updated by ttereshc about 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

It will be solved as a part of #4295

#5 Updated by ttereshc about 2 years ago

  • Related to deleted (Story #4295: As a user, a repository version has no advisories with the same id)

#6 Updated by ttereshc about 2 years ago

  • Is duplicate of Story #4295: As a user, a repository version has no advisories with the same id added

#7 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3 RPM blocker)

Please register to edit this issue

Also available in: Atom PDF