Project

Profile

Help

Issue #5005

RPM remote sync ignores "proxy_url" settings

Added by horakmar over 2 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

I cannot sync a repository from behind the corporate proxy. Worker tries to connect directly to url, ignoring proxy_url.
My remote definition:

{
    "count": 1,
    "next": null,
    "previous": null,
    "results": [
        {
            "_created": "2019-06-20T14:40:40.266506Z",
            "_href": "/pulp/api/v3/remotes/rpm/rpm/1022756e-cdf1-4126-85b2-ec51e480d942/",
            "_last_updated": "2019-06-20T14:40:40.266523Z",
            "_type": "rpm.rpm",                                                                          
            "download_concurrency": 20,
            "name": "bar",
            "policy": "immediate",
            "proxy_url": "http://http-proxy.cezdata.corp:8080",
            "ssl_ca_certificate": null,
            "ssl_client_certificate": null,
            "ssl_client_key": null,
            "ssl_validation": true,
            "url": "https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm-unsigned/",
            "validate": true
        }
    ]
}

Related issues

Is duplicate of Pulp - Issue #5011: remote's proxy_url setting not being used during syncCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ttereshc over 2 years ago

  • Project changed from Pulp to RPM Support
  • Category deleted (24)
  • Sprint/Milestone deleted (3.0.0)

#2 Updated by ttereshc over 2 years ago

There was a fix in pulpcore-plugin, merged recently.
https://github.com/pulp/pulpcore-plugin/commit/12fc10c77fb57ded703a0b3d3364b1bd34d31947

Please, try installing pulpcore-plugin from the master branch or wait for the next RC, it should be out this week.

#3 Updated by ttereshc over 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by ttereshc over 2 years ago

  • Related to Issue #5011: remote's proxy_url setting not being used during sync added

#5 Updated by ttereshc over 2 years ago

  • Related to deleted (Issue #5011: remote's proxy_url setting not being used during sync)

#6 Updated by ttereshc over 2 years ago

  • Is duplicate of Issue #5011: remote's proxy_url setting not being used during sync added

Please register to edit this issue

Also available in: Atom PDF